brcm2708: simplify gzip image generation
authorJohn Crispin <john@openwrt.org>
Sat, 21 Nov 2015 21:24:44 +0000 (21:24 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 21 Nov 2015 21:24:44 +0000 (21:24 +0000)
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
SVN-Revision: 47558

target/linux/brcm2708/image/Makefile

index cf263bdf01abb32d0dac89221f8e2b94af606c10..ecf6f71835f237ff08ac34ed28e5b318965acfdf 100644 (file)
@@ -11,16 +11,6 @@ include $(INCLUDE_DIR)/host.mk
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
-  define Image/gzip
-    gzip -9n -c $(1) > $(1).gz
-    mv $(1).gz $(BIN_DIR)
-  endef
-else
-  define Image/gzip
-  endef
-endif
-
 ### Image scripts ###
 define Build/gen-cfg
        cat config.txt > $@.config
@@ -49,7 +39,7 @@ endef
 define Build/sdcard-img
        ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
-       $(call Image/gzip,$@)
+       $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
 
 ### Device macros ###