[rdc] refresh 2.6.24 patches
authorGabor Juhos <juhosg@openwrt.org>
Sun, 8 Feb 2009 19:17:40 +0000 (19:17 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 8 Feb 2009 19:17:40 +0000 (19:17 +0000)
SVN-Revision: 14451

target/linux/rdc/patches-2.6.24/001-rdc3210_flash_map.patch
target/linux/rdc/patches-2.6.24/001-x86_generic_gpio.patch
target/linux/rdc/patches-2.6.24/002-r6040_ethernet.patch
target/linux/rdc/patches-2.6.24/003-rootfstype.patch
target/linux/rdc/patches-2.6.24/004-rdc_fixes.patch
target/linux/rdc/patches-2.6.24/004-yenta_mystery.patch
target/linux/rdc/patches-2.6.24/005-cmdline_setup.patch
target/linux/rdc/patches-2.6.24/005-fix_amit_breakage.patch
target/linux/rdc/patches-2.6.24/006-pci_ids.patch
target/linux/rdc/patches-2.6.24/600-x86_lzma.patch

index 0c407a114aa933a5a06a3e5f211a55c0b7de8eae..6da095df5881466531426a86907a6421de6bc0a4 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/maps/Kconfig
---- linux-2.6.17/drivers/mtd/maps/Kconfig      2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/mtd/maps/Kconfig  2006-09-24 20:28:11.000000000 +0200
-@@ -76,6 +76,50 @@
+--- a/drivers/mtd/maps/Kconfig
++++ b/drivers/mtd/maps/Kconfig
+@@ -117,6 +117,50 @@ config MTD_PNC2000
          PNC-2000 is the name of Network Camera product from PHOTRON
          Ltd. in Japan. It uses CFI-compliant flash.
  
@@ -52,11 +51,10 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/map
  config MTD_SC520CDP
        tristate "CFI Flash device mapped on AMD SC520 CDP"
        depends on X86 && MTD_CFI && MTD_CONCAT
-diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/maps/Makefile
---- linux-2.6.17/drivers/mtd/maps/Makefile     2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/mtd/maps/Makefile 2006-09-24 20:26:10.000000000 +0200
-@@ -28,6 +28,7 @@
- obj-$(CONFIG_MTD_PHYSMAP)     += physmap.o
+--- a/drivers/mtd/maps/Makefile
++++ b/drivers/mtd/maps/Makefile
+@@ -30,6 +30,7 @@ obj-$(CONFIG_MTD_PMC_MSP_EVM)   += pmcms
+ obj-$(CONFIG_MTD_PMC_MSP_RAMROOT)+= pmcmsp-ramroot.o
  obj-$(CONFIG_MTD_PNC2000)     += pnc2000.o
  obj-$(CONFIG_MTD_PCMCIA)      += pcmciamtd.o
 +obj-$(CONFIG_MTD_RDC3210)     += rdc3210.o
index ad2102f6321cfdd355a41c9afdb9d626d405674a..11c894bcf2437b8949b80702f52a3c90b473cc57 100644 (file)
@@ -1,15 +1,13 @@
-diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
-index 97b64d7..f8c1d32 100644
 --- a/arch/x86/Kconfig
 +++ b/arch/x86/Kconfig
-@@ -79,6 +79,10 @@ config GENERIC_BUG
-        default y
-        depends on BUG
-
+@@ -81,6 +81,10 @@ config GENERIC_BUG
+       default y
+       depends on BUG
 +config GENERIC_GPIO
 +       bool
 +       default n
 +
  config GENERIC_HWEIGHT
-        bool
-        default y
+       bool
+       default y
index 1b930252476e1c88835d25b68564275c9413a3e6..97d6e7d41fd70fe587afb9db893d4df74af37536 100644 (file)
@@ -1,9 +1,8 @@
-diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
---- linux-2.6.17/drivers/net/Kconfig   2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/net/Kconfig       2006-09-25 13:14:27.000000000 +0200
-@@ -1358,6 +1358,24 @@
-         <file:Documentation/networking/net-modules.txt>.  The module will be
-         called apricot.
+--- a/drivers/net/Kconfig
++++ b/drivers/net/Kconfig
+@@ -1449,6 +1449,24 @@ config APRICOT
+         To compile this driver as a module, choose M here. The module
+         will be called apricot.
  
 +config R6040
 +      tristate "RDC Fast-Ethernet support (EXPERIMENTAL)"
@@ -24,16 +23,15 @@ diff -urN linux-2.6.17/drivers/net/Kconfig linux-2.6.17.new/drivers/net/Kconfig
 +      depends on R6040
 +      default y
  config B44
-       tristate "Broadcom 4400 ethernet support (EXPERIMENTAL)"
-       depends on NET_PCI && PCI && EXPERIMENTAL
-diff -urN linux-2.6.17/drivers/net/Makefile linux-2.6.17.new/drivers/net/Makefile
---- linux-2.6.17/drivers/net/Makefile  2006-06-18 03:49:35.000000000 +0200
-+++ linux-2.6.17.new/drivers/net/Makefile      2006-09-25 13:14:45.000000000 +0200
-@@ -106,6 +106,7 @@
+       tristate "Broadcom 440x/47xx ethernet support"
+       depends on SSB_POSSIBLE
+--- a/drivers/net/Makefile
++++ b/drivers/net/Makefile
+@@ -116,6 +116,7 @@ obj-$(CONFIG_LNE390) += lne390.o 8390.o
  obj-$(CONFIG_NE3210) += ne3210.o 8390.o
- obj-$(CONFIG_NET_SB1250_MAC) += sb1250-mac.o
+ obj-$(CONFIG_SB1250_MAC) += sb1250-mac.o
  obj-$(CONFIG_B44) += b44.o
 +obj-$(CONFIG_R6040) += r6040.o
  obj-$(CONFIG_FORCEDETH) += forcedeth.o
- obj-$(CONFIG_NE_H8300) += ne-h8300.o 8390.o
+ obj-$(CONFIG_NE_H8300) += ne-h8300.o
+ obj-$(CONFIG_AX88796) += ax88796.o
index 34ac3d0a712ff0edc4d06d29bdc6795e82d1147b..3ad90472a8ad12c6fb041db7e02555d738ff8bad 100644 (file)
@@ -1,6 +1,6 @@
---- linux-2.6.19.2/init/do_mounts.c    2007-01-10 11:10:37.000000000 -0800
-+++ foo/init/do_mounts.c       2007-04-05 13:15:37.000000000 -0700
-@@ -243,6 +243,8 @@
+--- a/init/do_mounts.c
++++ b/init/do_mounts.c
+@@ -256,6 +256,8 @@ static void __init get_fs_names(char *pa
  {
        char *s = page;
  
index 47f8c08c682a00433fede6a5fb253a2c82a99b09..a42e5409c75c5564b741602ba7232b50f7a09752 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
---- linux-2.6.24/arch/x86/Kconfig      2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/Kconfig  2008-02-11 18:24:27.000000000 +0100
-@@ -300,6 +300,17 @@
+--- a/arch/x86/Kconfig
++++ b/arch/x86/Kconfig
+@@ -304,6 +304,17 @@ config X86_VSMP
          supposed to run on these EM64T-based machines.  Only choose this option
          if you have one of these machines.
  
@@ -19,10 +18,9 @@ diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
  endchoice
  
  config SCHED_NO_NO_OMIT_FRAME_POINTER
-diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c
---- linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c    2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c        2008-02-11 18:26:18.000000000 +0100
-@@ -30,6 +30,17 @@
+--- a/arch/x86/kernel/reboot_fixups_32.c
++++ b/arch/x86/kernel/reboot_fixups_32.c
+@@ -30,6 +30,17 @@ static void cs5536_warm_reset(struct pci
        udelay(50); /* shouldn't get here but be safe and spin a while */
  }
  
@@ -40,7 +38,7 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
  struct device_fixup {
        unsigned int vendor;
        unsigned int device;
-@@ -40,6 +51,7 @@
+@@ -40,6 +51,7 @@ static struct device_fixup fixups_table[
  { PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
  { PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
  { PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
@@ -48,10 +46,9 @@ diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/
  };
  
  /*
-diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_32
---- linux-2.6.24/arch/x86/Makefile_32  2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/Makefile_32      2008-02-11 18:25:12.000000000 +0100
-@@ -99,6 +99,11 @@
+--- a/arch/x86/Makefile_32
++++ b/arch/x86/Makefile_32
+@@ -99,6 +99,11 @@ mflags-$(CONFIG_X86_ES7000) := -Iinclude
  mcore-$(CONFIG_X86_ES7000)    := arch/x86/mach-default
  core-$(CONFIG_X86_ES7000)     := arch/x86/mach-es7000/
  
@@ -63,9 +60,8 @@ diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_3
  # Xen paravirtualization support
  core-$(CONFIG_XEN)            += arch/x86/xen/
  
-diff -urN linux-2.6.24/include/asm-x86/timex.h linux-2.6.24.new/include/asm-x86/timex.h
---- linux-2.6.24/include/asm-x86/timex.h       2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/include/asm-x86/timex.h   2008-02-11 18:25:43.000000000 +0100
+--- a/include/asm-x86/timex.h
++++ b/include/asm-x86/timex.h
 @@ -7,6 +7,8 @@
  
  #ifdef CONFIG_X86_ELAN
index 7faabdf7a30784fcf21a2f041052046a8dc72b29..7f202c6c7719bfc71d29fbf303c2ce8a1e5f3213 100644 (file)
@@ -1,6 +1,6 @@
---- linux-2.6.24.7.orig/drivers/pcmcia/yenta_socket.c  2008-10-26 08:30:07.000000000 -0700
-+++ linux-2.6.24.7/drivers/pcmcia/yenta_socket.c       2008-10-26 08:54:27.000000000 -0700
-@@ -1171,6 +1171,17 @@
+--- a/drivers/pcmcia/yenta_socket.c
++++ b/drivers/pcmcia/yenta_socket.c
+@@ -1171,6 +1171,17 @@ static int __devinit yenta_probe (struct
  
        /* We must finish initialization here */
  
index 007477e836a5e069ff2132f215b2e9f49dd58bf1..99b54b72a2541867445527bd0185b01f03a9ba58 100644 (file)
@@ -1,6 +1,6 @@
---- linux-2.6.24.7/arch/x86/kernel/setup_32.c  2008-05-07 01:22:34.000000000 +0200
-+++ linux-2.6.24.7.new/arch/x86/kernel/setup_32.c      2008-08-05 14:54:58.000000000 +0200
-@@ -609,6 +609,7 @@
+--- a/arch/x86/kernel/setup_32.c
++++ b/arch/x86/kernel/setup_32.c
+@@ -609,6 +609,7 @@ void __init setup_arch(char **cmdline_p)
                print_memory_map("user");
        }
  
index eabfd04ed33bdff8b74b818db5bb37eb5a018c3a..5be29df3569021598e0591effa5a5aeaf1666460 100644 (file)
@@ -1,7 +1,6 @@
-diff -ru linux-2.6.24.7.orig/arch/x86/boot/boot.h linux-2.6.24.7/arch/x86/boot/boot.h
---- linux-2.6.24.7.orig/arch/x86/boot/boot.h   2008-10-26 20:18:14.000000000 -0700
-+++ linux-2.6.24.7/arch/x86/boot/boot.h        2008-10-26 20:18:36.000000000 -0700
-@@ -60,7 +60,7 @@
+--- a/arch/x86/boot/boot.h
++++ b/arch/x86/boot/boot.h
+@@ -60,7 +60,7 @@ static inline void outl(u32 v, u16 port)
  {
        asm volatile("outl %0,%1" : : "a" (v), "dN" (port));
  }
@@ -10,9 +9,8 @@ diff -ru linux-2.6.24.7.orig/arch/x86/boot/boot.h linux-2.6.24.7/arch/x86/boot/b
  {
        u32 v;
        asm volatile("inl %1,%0" : "=a" (v) : "dN" (port));
-diff -ru linux-2.6.24.7.orig/arch/x86/boot/pm.c linux-2.6.24.7/arch/x86/boot/pm.c
---- linux-2.6.24.7.orig/arch/x86/boot/pm.c     2008-10-26 19:55:50.000000000 -0700
-+++ linux-2.6.24.7/arch/x86/boot/pm.c  2008-10-26 21:38:12.000000000 -0700
+--- a/arch/x86/boot/pm.c
++++ b/arch/x86/boot/pm.c
 @@ -16,6 +16,9 @@
  
  #include "boot.h"
@@ -23,7 +21,7 @@ diff -ru linux-2.6.24.7.orig/arch/x86/boot/pm.c linux-2.6.24.7/arch/x86/boot/pm.
  
  /*
   * Invoke the realmode switch hook if present; otherwise
-@@ -160,6 +163,16 @@
+@@ -160,6 +163,16 @@ void go_to_protected_mode(void)
                die();
        }
  
index cd4c01d920a842f5e29f59b634b5b248a2e79017..96ab2b14e24f88e8eb54537199cf547643816cee 100644 (file)
@@ -1,8 +1,6 @@
-diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
-index 55f307f..4a1aa34 100644
 --- a/include/linux/pci_ids.h
 +++ b/include/linux/pci_ids.h
-@@ -2076,6 +2076,13 @@
+@@ -2106,6 +2106,13 @@
  #define PCI_DEVICE_ID_HERC_WIN                0x5732
  #define PCI_DEVICE_ID_HERC_UNI                0x5832
  
index 266c042971b8199e11480a53a42b69bc335c622e..9d94950b5cfb0b8adcba941ec3e29f83dc1564e9 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefile.lib
---- linux-2.6.19.2/scripts/Makefile.lib        2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/scripts/Makefile.lib    2007-04-15 23:51:54.000000000 +0200
-@@ -162,4 +162,9 @@
+--- a/scripts/Makefile.lib
++++ b/scripts/Makefile.lib
+@@ -166,4 +166,9 @@ cmd_objcopy = $(OBJCOPY) $(OBJCOPYFLAGS)
  quiet_cmd_gzip = GZIP    $@
  cmd_gzip = gzip -f -9 < $< > $@
  
@@ -12,17 +11,15 @@ diff -urN linux-2.6.19.2/scripts/Makefile.lib linux-2.6.19.2.new/scripts/Makefil
 +cmd_lzma = bash -e scripts/lzma_kern $< $@ -lc7 -lp0 -pb0
 +# to use lzmacomp,
 +# cmd_lzma = lzmacomp $< 700 > $@
-diff -u linux/scripts/lzma_kern linux/scripts/lzma_kern
---- linux/scripts/lzma_kern    2007-07-27 20:18:17.013014750 -0700
-+++ linux/scripts/lzma_kern    2007-07-27 20:18:17.013014750 -0700
+--- /dev/null
++++ b/scripts/lzma_kern
 @@ -0,0 +1,4 @@
 +get-size() { echo "$5" ;}
 +printf -v len '%.8x' "$(get-size $(ls -l "$1"))"
 +lzma e "$@"
 +echo -ne "\x$(echo $len | cut -c 7,8)\x$(echo $len | cut -c 5,6)\x$(echo $len | cut -c 3,4)\x$(echo $len | cut -c 1,2)" >> "$2"
-diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32
---- linux-2.6.24/arch/x86/boot/compressed/Makefile_32  2008-01-24 23:58:37.000000000 +0100
-+++ linux-2.6.24.new/arch/x86/boot/compressed/Makefile_32      2008-02-13 15:21:03.000000000 +0100
+--- a/arch/x86/boot/compressed/Makefile_32
++++ b/arch/x86/boot/compressed/Makefile_32
 @@ -4,8 +4,8 @@
  # create a compressed vmlinux image from the original vmlinux
  #
@@ -34,7 +31,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
  EXTRA_AFLAGS  := -traditional
  
  LDFLAGS_vmlinux := -T
-@@ -17,7 +17,7 @@
+@@ -17,7 +17,7 @@ KBUILD_CFLAGS  := -m32 -D__KERNEL__ $(LI
           $(call cc-option,-fno-stack-protector)
  LDFLAGS := -m elf_i386
  
@@ -43,7 +40,7 @@ diff -urN linux-2.6.24/arch/x86/boot/compressed/Makefile_32 linux-2.6.24.new/arc
        $(call if_changed,ld)
        @:
  
-@@ -37,14 +37,14 @@
+@@ -37,14 +37,14 @@ $(obj)/vmlinux.bin.all: $(vmlinux.bin.al
        $(call if_changed,relocbin)
  
  ifdef CONFIG_RELOCATABLE