toolchain: fix libpthread package for musl based toolchains (#12651)
authorFlorian Fainelli <florian@openwrt.org>
Wed, 9 Jan 2013 15:36:43 +0000 (15:36 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 9 Jan 2013 15:36:43 +0000 (15:36 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35069

package/toolchain/Makefile

index 84fc3e6..ec5508a 100644 (file)
@@ -451,6 +451,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 
   define Package/libpthread/install
        $(INSTALL_DIR) $(1)/lib
+  ifneq ($(CONFIG_USE_MUSL),y)
        $(CP) \
                $(TOOLCHAIN_DIR)/lib/libpthread.so.* \
                $(if $(BUILD_LIBGCC),\
@@ -458,6 +459,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
                        $(TOOLCHAIN_DIR)/lib/libpthread-$(LIBC_SO_VERSION).so \
                ) \
                $(1)/lib/
+  endif
   endef
 
   define Package/libthread-db/install