move the crda dependency to the kmod-cfg80211 package, get rid of crda's dependency...
authorFelix Fietkau <nbd@openwrt.org>
Tue, 20 Jul 2010 01:54:16 +0000 (01:54 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 20 Jul 2010 01:54:16 +0000 (01:54 +0000)
SVN-Revision: 22304

package/crda/Makefile
package/hostapd/Makefile
package/mac80211/Makefile

index 7036dcfd6fd0bdf1f49ed85d5221fc8346e08ea8..9e9be188ff28043dac78071e700690aed9036412 100644 (file)
@@ -28,7 +28,7 @@ define Package/crda
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Central Regulatory Domain Agent (CRDA)
-  DEPENDS:=+kmod-mac80211 +libnl-tiny
+  DEPENDS:=+libnl-tiny
   URL:=http://wireless.kernel.org/en/developers/Regulatory/CRDA
 endef
 
index 3e4864dcc06d9b7989eac5c9e8467717836e0dbb..5bcaba945809ccec92e9f847820aa492e85a622c 100644 (file)
@@ -82,7 +82,7 @@ ifneq ($(LOCAL_TYPE),hostapd)
        CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
 endif
 
-DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny +PACKAGE_kmod-mac80211:crda @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
+DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!(TARGET_avr32||TARGET_etrax)||BROKEN)
 
 define Package/hostapd/Default
   SECTION:=net
index 050447d052ed44189f9c3fbe12d089e764328c90..03a1a4b0db679efe46abd26e93414f426d84fcb9 100644 (file)
@@ -41,7 +41,7 @@ endef
 define KernelPackage/cfg80211
   $(call KernelPackage/mac80211/Default)
   TITLE:=cfg80211 - wireless configuration API
-  DEPENDS+= +wireless-tools +iw @!LINUX_2_6_25
+  DEPENDS+= +wireless-tools +iw @!LINUX_2_6_25 +crda
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.33)),1)
   FILES:= \
        $(PKG_BUILD_DIR)/compat/compat.ko \