package/kernel: add IKCONFIG module option
authorFelix Fietkau <nbd@openwrt.org>
Fri, 19 Oct 2012 17:47:22 +0000 (17:47 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 19 Oct 2012 17:47:22 +0000 (17:47 +0000)
Add an option for building the configs.ko module which provides
kernel configuration via /proc/config.gz

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 33865

package/kernel/modules/other.mk

index f370f65129b0360a99669b225ddd13bcefb73c95..352af2894e979fda003ca00de4f2ce26b5a73238 100644 (file)
@@ -697,3 +697,18 @@ define KernelPackage/regmap/description
 endef
 
 $(eval $(call KernelPackage,regmap))
+
+define KernelPackage/ikconfig
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Kernel configuration via /proc/config.gz
+  KCONFIG:=CONFIG_IKCONFIG \
+          CONFIG_IKCONFIG_PROC=y
+  FILES:=$(LINUX_DIR)/kernel/configs.ko
+  AUTOLOAD:=$(call AutoLoad,70,configs)
+endef
+
+define KernelPackage/ikconfig/description
+       Kernel configuration via /proc/config.gz
+endef
+
+$(eval $(call KernelPackage,ikconfig))