support the autoreconf fixup without libtool
authorFelix Fietkau <nbd@openwrt.org>
Fri, 10 Dec 2010 15:20:51 +0000 (15:20 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 10 Dec 2010 15:20:51 +0000 (15:20 +0000)
SVN-Revision: 24423

include/autotools.mk

index b236aace48b9c644845f77686a38633239d86f58..b4eb7bfc4e18104306a75229bf05fc2fa586fd70 100644 (file)
@@ -45,3 +45,8 @@ ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
  endif
 endif
 
+ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
+  ifeq ($(filter autoreconf,$(Hooks/Configure/Pre)),)
+    Hooks/Configure/Pre += autoreconf
+  endif
+endif