Add httptunnel UCI config and init script from #2886
authorFlorian Fainelli <florian@openwrt.org>
Wed, 2 Jan 2008 15:19:27 +0000 (15:19 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 2 Jan 2008 15:19:27 +0000 (15:19 +0000)
SVN-Revision: 10085

net/httptunnel/Makefile
net/httptunnel/files/httptunnel.conf [new file with mode: 0644]
net/httptunnel/files/httptunnel.init [new file with mode: 0644]

index c718aa383b0f2efcd580d3399368e52a3255a887..376bdd9547ce17f1c104d3d43b86daf606cb81c5 100644 (file)
@@ -24,7 +24,7 @@ define Package/httptunnel
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=+libopenssl
-  TITLE:=bidirectional virtual data connection tunnelled in HTTP requests
+  TITLE:=bidirectional tunnel in HTTP requests
   URL:=http://www.nocrew.org/software/httptunnel.html
 endef
 
@@ -37,6 +37,10 @@ define Package/httptunnel/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hts $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/htc $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/httptunnel.init $(1)/etc/init.d/httptunnel
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/httptunnel.conf $(1)/etc/config/httptunnel      
 endef
 
 $(eval $(call BuildPackage,httptunnel))
diff --git a/net/httptunnel/files/httptunnel.conf b/net/httptunnel/files/httptunnel.conf
new file mode 100644 (file)
index 0000000..fb5a5dd
--- /dev/null
@@ -0,0 +1,4 @@
+config httptunnel
+        option destination 'localhost:443'
+       option sourceport '80'
+
diff --git a/net/httptunnel/files/httptunnel.init b/net/httptunnel/files/httptunnel.init
new file mode 100644 (file)
index 0000000..6c84618
--- /dev/null
@@ -0,0 +1,27 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2007 OpenWrt.org
+START=70
+BIN=hts
+
+start_httptunnel() {
+    local section="$1"    
+    
+    config_get destination "$section" destination
+    config_get sourceport "$section" sourceport 
+    
+    echo start httptunnel: dest: "$destination", src: "$sourceport"
+    
+    $BIN --forward-port "$destination" "$sourceport"
+}
+
+
+start() {
+    config_load httptunnel
+    config_foreach start_httptunnel httptunnel
+}
+
+stop() {
+        ps aux | grep hts |  awk '{print }' | \
+            xargs kill 2> /dev/null
+}
+                                                                       
\ No newline at end of file