libnl: Install include files into libnl3
authorFelix Fietkau <nbd@openwrt.org>
Fri, 2 Oct 2015 16:24:15 +0000 (16:24 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 2 Oct 2015 16:24:15 +0000 (16:24 +0000)
Install header files into same location as pkgconfig/libnl-3.0.pc says:
  Cflags: -I${includedir}/libnl3

Signed-off-by: Bruno Randolf <br1@einfach.org>
SVN-Revision: 47102

package/libs/libnl/Makefile

index 857bbe272cc72f6ec646864722e5997a51d0f231..241e9a76ed58aa92703292d50c474bac7a70dfca 100644 (file)
@@ -85,8 +85,8 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(INSTALL_DIR) $(1)/usr/include/libnl $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl/
+       $(INSTALL_DIR) $(1)/usr/include/libnl3 $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/libnl3/* $(1)/usr/include/libnl3/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc $(1)/usr/lib/pkgconfig