[package] hostapd: fix ap/sta regression which got accidentally introduced by r32829...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Aug 2012 11:13:12 +0000 (11:13 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Aug 2012 11:13:12 +0000 (11:13 +0000)
SVN-Revision: 33053

package/hostapd/Makefile
package/hostapd/files/wpa_supplicant.sh

index 4fedd1b9379901d42a68acc55fbaf790154ce2a7..122ee9b1a4cf5471073e7155a98e9c164f8cc9cc 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
 PKG_VERSION:=20120428
 
 PKG_NAME:=hostapd
 PKG_VERSION:=20120428
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_REV:=1f0cc27eb98f7d1af9c64d0752238184cbdb9a24
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_REV:=1f0cc27eb98f7d1af9c64d0752238184cbdb9a24
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index babacd79689e77055494864bd31e77ffb36deb7c..5c4bd93d02d3774470de890a64ace6e0a7d7537c 100644 (file)
@@ -127,6 +127,8 @@ wpa_supplicant_setup_vif() {
        local fixed_freq bssid1 beacon_interval brates mrate
        config_get ifname "$vif" ifname
        config_get bridge "$vif" bridge
        local fixed_freq bssid1 beacon_interval brates mrate
        config_get ifname "$vif" ifname
        config_get bridge "$vif" bridge
+       config_get ssid "$vif" ssid
+       config_get bssid "$vif" bssid
        bssid1=${bssid:+"bssid=$bssid"}
        beacon_interval=${beacon_int:+"beacon_interval=$beacon_int"}
 
        bssid1=${bssid:+"bssid=$bssid"}
        beacon_interval=${beacon_int:+"beacon_interval=$beacon_int"}