package/valgrind: fix build on eglibc
authorNicolas Thill <nico@openwrt.org>
Sat, 14 Feb 2015 13:53:51 +0000 (13:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 14 Feb 2015 13:53:51 +0000 (13:53 +0000)
configure tries to guess pagesize by calling getconf, provided by eglibc and compiled for the target, not the host.

Signed-off-by: Nicolas Thill <nico@openwrt.org>
SVN-Revision: 44445

package/devel/valgrind/Makefile

index e2c7f6728069283fcf12588099eade5eb283eacf..354e3c417fe88378ead87680a64c567cf3b56918 100644 (file)
@@ -101,7 +101,8 @@ CONFIGURE_ARGS += \
        --disable-valgrindmi \
        --disable-tui \
        --disable-valgrindtk \
-       --without-included-gettext
+       --without-included-gettext \
+       --with-pagesize=4 \
 
 define Package/valgrind/install        
        $(INSTALL_DIR) $(1)/usr/bin