[packages] libgphoto2, gphoto2: update to 2.4.8
authorStephen Walker <stephendwalker@gmail.com>
Sun, 31 Jan 2010 14:48:46 +0000 (14:48 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Sun, 31 Jan 2010 14:48:46 +0000 (14:48 +0000)
SVN-Revision: 19451

libs/libgphoto2/Makefile
multimedia/gphoto2/Makefile

index e3d163d5410c41e9522f5c3afb14305c2caa5e54..033f3dd1dfdc34a2fa22ccb7ef916a39e4717ae2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgphoto2
-PKG_VERSION:=2.4.7
+PKG_VERSION:=2.4.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
-PKG_MD5SUM:=3c1f1b1e56214e83b97e2bc7aadba4c5
+PKG_MD5SUM:=7753f17dff15702466337aab05209a71
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -58,12 +59,8 @@ CONFIGURE_VARS += \
        LIBUSB_LIBS="$$$$LDFLAGS -lusb" \
        LIBS="-lltdl" \
 
-define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               LIBLTDL="" \
-               all install
-endef
+MAKE_FLAGS += \
+       LIBLTDL="" \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/bin
index f16e62ed6c896a309855084225fc5224deadef0b..0a8fc0c429a36a654550bc480774cf527b7355cc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gphoto2
-PKG_VERSION:=2.4.7
+PKG_VERSION:=2.4.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/gphoto
-PKG_MD5SUM:=a0bd7629040735f16e510b63edf386dd
+PKG_MD5SUM:=401e403ea6e8301d6c87cbe7cd892b8b
 
-PKG_FIXUP = libtool
+PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -46,7 +47,7 @@ CONFIGURE_VARS += \
 
 define Package/gphoto2/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/gphoto2/$(PKG_NAME) $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,gphoto2))