Add nagios
authorFlorian Fainelli <florian@openwrt.org>
Thu, 17 May 2007 22:46:16 +0000 (22:46 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 17 May 2007 22:46:16 +0000 (22:46 +0000)
SVN-Revision: 7269

net/nagios/Makefile [new file with mode: 0644]

diff --git a/net/nagios/Makefile b/net/nagios/Makefile
new file mode 100644 (file)
index 0000000..7f4a8c5
--- /dev/null
@@ -0,0 +1,57 @@
+# 
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=nagios
+PKG_VERSION:=2.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/nagios
+PKG_MD5SUM:=b6e3a21c91edb063c00712c6001e15ec
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/nagios
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpthread +microperl
+  TITLE:=service and network monitoring program
+  DESCRIPTION:=\
+       service and network monitoring program
+  URL:=http://www.nagios.org/
+endef
+
+define Package/send-nagios/conffiles
+/etc/send_nagios.cfg
+endef
+
+define Build/Configure
+       $(call Build/Configure/Default,\
+               --with-nagios-user="root" \
+               --with-nagios-group="root" \
+       )
+endef
+
+define Build/Compile
+       $(call Build/Compile/Default,\
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               INSTALL_OPTS="" \
+               all install install-config \
+       )
+endef
+
+define Package/nagios/install
+       $(CP) $(PKG_INSTALL_DIR) $(1)/
+endef
+
+$(eval $(call BuildPackage,nagios))