6rd: make host dependency more specific
authorSteven Barth <cyrus@openwrt.org>
Tue, 10 Mar 2015 08:43:54 +0000 (08:43 +0000)
committerSteven Barth <cyrus@openwrt.org>
Tue, 10 Mar 2015 08:43:54 +0000 (08:43 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 44636

package/network/ipv6/6rd/Makefile
package/network/ipv6/6rd/files/6rd.sh

index d3e4bf69746d6840c65619b4859ede93d8958cfe..f9b7eae1391a820862f22c6e1d578d543e361261 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6rd
-PKG_VERSION:=8
+PKG_VERSION:=9
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index 287f569885a32b5cd1eee5b8aace2e0966a05969..b48513640e848535cb51d82cdf4c7d040235e782 100644 (file)
@@ -23,7 +23,7 @@ proto_6rd_setup() {
                return
        }
 
-       ( proto_add_host_dependency "$cfg" 0.0.0.0 "$tunlink" )
+       ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
 
        [ -z "$ipaddr" ] && {
                local wanif="$tunlink"