[packages] pure-ftpd: update to 1.0.28
authorStephen Walker <stephendwalker@gmail.com>
Thu, 18 Feb 2010 05:21:38 +0000 (05:21 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Thu, 18 Feb 2010 05:21:38 +0000 (05:21 +0000)
SVN-Revision: 19701

net/pure-ftpd/Makefile

index 15ce3cf13849c4282e1ddece143b8bd64f4298b8..6ee79ef0e460d2489cfc05c53a083982c1c776ef 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pure-ftpd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pure-ftpd
-PKG_VERSION:=1.0.27
+PKG_VERSION:=1.0.28
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://download.pureftpd.org/pub/pure-ftpd/releases
-PKG_MD5SUM:=7d18544384aa1649d483ba86518ed34e
+PKG_MD5SUM:=a6f63e31be494df4e3174535bf8d6be1
+
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -43,12 +45,19 @@ CONFIGURE_ARGS += \
        --with-virtualchroot \
 
 define Package/pure-ftpd/install
        --with-virtualchroot \
 
 define Package/pure-ftpd/install
-       $(INSTALL_DIR) $(1)/etc/config $(1)/etc/init.d $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
        $(INSTALL_CONF) ./files/$(PKG_NAME).config $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
        $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptracetest $(1)/usr/sbin
-       $(INSTALL_BIN) $(foreach i,ftpd pw ftpwho mrtginfo pwconvert quotacheck statsdecode uploadscript authd, \
-               $(PKG_BUILD_DIR)/src/pure-$(i)) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/bin/pure-{pw,pwconvert,statsdecode} \
+               $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ptracetest $(1)/usr/sbin/
+       $(INSTALL_BIN) \
+               $(PKG_INSTALL_DIR)/usr/sbin/pure-{authd,ftpd,ftpwho,mrtginfo,quotacheck,uploadscript} \
+               $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,pure-ftpd))
 endef
 
 $(eval $(call BuildPackage,pure-ftpd))