[kirkwood] Fix mv_cesa module dependencies and .ko file location
authorLars-Peter Clausen <lars@metafoo.de>
Tue, 28 Sep 2010 16:32:08 +0000 (16:32 +0000)
committerLars-Peter Clausen <lars@metafoo.de>
Tue, 28 Sep 2010 16:32:08 +0000 (16:32 +0000)
Thanks KanjiMonster & Memphiz

SVN-Revision: 23145

target/linux/kirkwood/modules.mk

index ed7fe883a544925a217510ad806c370cf1cef18d..736c82c315a727df57fe08737f1fdda25e1f9aaf 100644 (file)
@@ -2,10 +2,10 @@
 define KernelPackage/crypto-mv_cesa
    TITLE:=Marvell crypto engine
    KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
-   FILES:=$(LINUX_DIR)/crypto/mv_cesa.ko
+   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
    AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
    SUBMENU:=Cryptographic API modules
-   DEPENDS:=kmod-crypto-core
+   DEPENDS:=kmod-crypto-core @TARGET_kirkwood
 endef
 
 $(eval $(call KernelPackage,crypto-mv_cesa))