[packages] transmission: update to 2.50, drop open_file_limit - has been removed...
authorCezary Jackiewicz <cezary@eko.one.pl>
Thu, 16 Feb 2012 12:31:48 +0000 (12:31 +0000)
committerCezary Jackiewicz <cezary@eko.one.pl>
Thu, 16 Feb 2012 12:31:48 +0000 (12:31 +0000)
SVN-Revision: 30585

net/transmission/Makefile
net/transmission/files/transmission.config
net/transmission/files/transmission.init

index bd115f373f303362ec4ba8fb4e32a05395967ad0..6f7f656238bc21d28518603e12c99088eaa2aaec 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=transmission
-PKG_VERSION:=2.42
-PKG_RELEASE:=4
+PKG_VERSION:=2.50
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://mirrors.m0k.org/transmission/files
-PKG_MD5SUM:=2ade0818d465779bd956b8b72ea56b02
+PKG_MD5SUM:=c3611108e34fe6ebdcf93da5beb89045
 
 PKG_FIXUP:=libtool
 PKG_INSTALL:=1
index 912f52f4b95ee5769e29b974e2fd98921aab241c..e697f2b62997f80ca85b247583b6e4029e78b390 100644 (file)
@@ -26,7 +26,6 @@ config transmission
        option lazy_bitfield_enabled true
        option lpd_enabled false
        option message_level 1
-       option open_file_limit 32
        option peer_congestion_algorithm ''
        option peer_limit_global 240
        option peer_limit_per_torrent 60
index fc8fe9ac3141de378b35c3ca44ed2d2df2de13a3..669e710ec3d6b3d9258251d32886f4619ecf30ac 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 
 START=99
 
@@ -43,8 +43,6 @@ section_enabled() {
 start_instance() {
        local s="$1"
        local user
-       local open_file_limit=0
-       local ulimit_files=$(ulimit -n)
 
        section_enabled "$section" || return 1
 
@@ -66,7 +64,7 @@ start_instance() {
                cache_size_mb download_queue_enabled download_queue_size \
                dht_enabled encryption idle_seeding_limit idle_seeding_limit_enabled \
                incomplete_dir_enabled lazy_bitfield_enabled lpd_enabled message_level \
-               open_file_limit peer_limit_global peer_limit_per_torrent peer_port \
+               peer_limit_global peer_limit_per_torrent peer_port \
                peer_port_random_high peer_port_random_low peer_port_random_on_start \
                pex_enabled port_forwarding_enabled preallocation prefetch_enabled \
                ratio_limit ratio_limit_enabled rename_partial_files rpc_authentication_required \
@@ -86,13 +84,6 @@ start_instance() {
        echo "\""invalid-key"\": false" >> $config_file
        echo "}" >> $config_file
 
-       config_get open_file_limit "$s" 'open_file_limit' 32
-       open_limit_files=$(($open_file_limit + 8))
-
-       if [ ${open_file_limit} -gt ${ulimit_files} ]; then
-               ulimit -n $open_limit_files
-       fi
-
        SERVICE_UID="$user" \
        service_start /usr/bin/transmission-daemon -g $config_dir
 }