kirkwood/dockstar: use ubi(kernel, squashfs, ubifs) images
authorLuka Perkov <luka@openwrt.org>
Mon, 14 Mar 2016 17:06:09 +0000 (17:06 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 14 Mar 2016 17:06:09 +0000 (17:06 +0000)
The new image requires `bootz` because of devicetree appending.
To flash a new image boot initramfs:

  tftpboot 0x800000 openwrt-kirkwood-dockstar-initramfs-kernel.bin
  bootz 0x800000

  # detach if already attached
  ubidetach -p /dev/$(grep ubi /proc/mtd|awk -F: '{print $1}')
  # scp openwrt-kirkwood-dockstar-squashfs-factory.bin /tmp
  ubiformat -f /tmp/openwrt-kirkwood-dockstar-squashfs-factory.bin
  # attach is important to resize rootfs_data otherwise it wont boot
  ubiattach -p /dev/$(grep ubi /proc/mtd|awk -F: '{print $1}')

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
SVN-Revision: 49010

target/linux/kirkwood/base-files/lib/upgrade/platform.sh
target/linux/kirkwood/image/Makefile

index c33229a41be89cf2d26476250735f87e1beed3fb..be5f1016736770ce2896a3ade0a1dcb193c972e9 100644 (file)
@@ -14,6 +14,10 @@ platform_check_image() {
                }
                return 0
                ;;
                }
                return 0
                ;;
+       "dockstar")
+               nand_do_platform_check $board $1
+               return $?
+               ;;
        esac
 
        echo "Sysupgrade is not yet supported on $board."
        esac
 
        echo "Sysupgrade is not yet supported on $board."
@@ -30,3 +34,13 @@ platform_do_upgrade() {
                ;;
        esac
 }
                ;;
        esac
 }
+
+platform_pre_upgrade() {
+       local board=$(kirkwood_board_name)
+
+       case "$board" in
+       "dockstar")
+               nand_do_upgrade $1
+               ;;
+       esac
+}
index 9a2c2e4fb2c41e82caaabc1d17ec4aa0967efae3..bc42befc182490c05538b6e200c9d037b2427ed8 100644 (file)
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/image.mk
 
 DEVICE_VARS += DEVICE_DTS KERNEL_SIZE PAGESIZE BLOCKSIZE SUBPAGESIZE KERNEL_IN_UBI
 KERNEL_LOADADDR:=0x8000
 
 DEVICE_VARS += DEVICE_DTS KERNEL_SIZE PAGESIZE BLOCKSIZE SUBPAGESIZE KERNEL_IN_UBI
 KERNEL_LOADADDR:=0x8000
-TARGET_DEVICES = linksys-audi linksys-viper
+TARGET_DEVICES = linksys-audi linksys-viper dockstar
 
 define Device/Default
   KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
 
 define Device/Default
   KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
@@ -161,9 +161,6 @@ endef
 Image/BuildKernel/Template/Generic=$(call Image/BuildKernel/Template)
 Image/InstallKernel/Template/Generic=$(call Image/InstallKernel/Template)
 
 Image/BuildKernel/Template/Generic=$(call Image/BuildKernel/Template)
 Image/InstallKernel/Template/Generic=$(call Image/InstallKernel/Template)
 
-Image/BuildKernel/Template/DOCKSTAR=$(call Image/BuildKernel/Template,dockstar)
-Image/InstallKernel/Template/DOCKSTAR=$(call Image/InstallKernel/Template,dockstar)
-
 Image/BuildKernel/Template/GOFLEXHOME=$(call Image/BuildKernel/Template,goflexhome)
 Image/InstallKernel/Template/GOFLEXHOME=$(call Image/InstallKernel/Template,goflexhome)
 
 Image/BuildKernel/Template/GOFLEXHOME=$(call Image/BuildKernel/Template,goflexhome)
 Image/InstallKernel/Template/GOFLEXHOME=$(call Image/InstallKernel/Template,goflexhome)