glib2 now needs the dev package from glib 2.0 installed on the host,
authorMartin Janitschke <noeoeh@web.de>
Mon, 6 Aug 2007 23:10:20 +0000 (23:10 +0000)
committerMartin Janitschke <noeoeh@web.de>
Mon, 6 Aug 2007 23:10:20 +0000 (23:10 +0000)
thanks to sn9 for coming up with the problem :). nuke the patch
which hide the problem.

SVN-Revision: 8361

libs/glib2/Makefile
libs/glib2/patches/001-no_glib_marshal.patch [deleted file]

index cd0f39a..321093c 100644 (file)
@@ -79,3 +79,8 @@ define Package/glib2/install
 endef
 
 $(eval $(call BuildPackage,glib2))
+
+$(eval $(call RequireCommand,glib-genmarshal, \
+       $(PKG_NAME) requires the glib2 dev (named like libglib2.0-dev, \
+       depending of your package manager) package be installed on the host-system. \
+))
diff --git a/libs/glib2/patches/001-no_glib_marshal.patch b/libs/glib2/patches/001-no_glib_marshal.patch
deleted file mode 100644 (file)
index 984a8e8..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -urN glib-2.12.12/configure glib-2.12.12.new/configure
---- glib-2.12.12/configure     2007-05-02 01:20:31.000000000 +0200
-+++ glib-2.12.12.new/configure 2007-05-11 09:24:21.000000000 +0200
-@@ -43081,8 +43081,7 @@
-   if test x$GLIB_GENMARSHAL = xno; then
-     { { echo "$as_me:$LINENO: error: Could not find a glib-genmarshal in your PATH" >&5
--echo "$as_me: error: Could not find a glib-genmarshal in your PATH" >&2;}
--   { (exit 1); exit 1; }; }
-+echo "$as_me: error: Could not find a glib-genmarshal in your PATH" >&2;} }
-   fi
- fi