[package] tinyproxy: fix creation of pid and log (#7641)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 11:39:13 +0000 (11:39 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 31 Jul 2010 11:39:13 +0000 (11:39 +0000)
SVN-Revision: 22431

net/tinyproxy/Makefile
net/tinyproxy/patches/020-config_and_pid-path.patch [new file with mode: 0644]

index 50a23ab2728cdfcad3460902d3cc85698877fbfb..96f3bf781c139133da9907c93d7913233f84cd04 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=tinyproxy
 PKG_VERSION:=1.8.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.banu.com/pub/tinyproxy/1.8/
diff --git a/net/tinyproxy/patches/020-config_and_pid-path.patch b/net/tinyproxy/patches/020-config_and_pid-path.patch
new file mode 100644 (file)
index 0000000..2e9f9e4
--- /dev/null
@@ -0,0 +1,15 @@
+diff -Nur a/src/main.c b/src/main.c
+--- a/src/main.c        2010-07-17 11:57:25.000000000 +0200
++++ b/src/main.c        2010-07-17 11:58:52.000000000 +0200
+@@ -326,8 +326,8 @@
+         conf->errorpages = NULL;
+         conf->stathost = safestrdup (TINYPROXY_STATHOST);
+         conf->idletimeout = MAX_IDLE_TIME;
+-        conf->logf_name = safestrdup (LOCALSTATEDIR "/log/tinyproxy/tinyproxy.log");
+-        conf->pidpath = safestrdup (LOCALSTATEDIR "/run/tinyproxy/tinyproxy.pid");
++        conf->logf_name = safestrdup (LOCALSTATEDIR "/log/tinyproxy.log");
++        conf->pidpath = safestrdup (LOCALSTATEDIR "/tinyproxy.pid");
+ }
+ /**
+