[packages] cups: update to v1.3.10
authorNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 22:18:45 +0000 (22:18 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 27 Apr 2009 22:18:45 +0000 (22:18 +0000)
SVN-Revision: 15455

net/cups/Makefile
net/cups/patches/100-makefile-targets.patch
net/cups/patches/130-no_chown.patch
net/cups/patches/140-uname.patch
net/cups/patches/150-64bit_host_fix.patch
net/cups/patches/160-stack-protector.patch

index 101f712c36b1b1b684b15259d4633239f40d7822..c8cd6d2806b5c442945e27d9af4871a24ab170e6 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cups
-PKG_VERSION:=1.3.7
-PKG_RELEASE:=5
+PKG_VERSION:=1.3.10
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-source.tar.bz2
 PKG_SOURCE_URL:= \
        http://ftp.rz.tu-bs.de/pub/mirror/ftp.easysw.com/ftp/pub/cups/$(PKG_VERSION) \
        ftp://ftp.easysw.com/pub/cups/$(PKG_VERSION) \
        ftp://ftp3.easysw.com/pub/cups/$(PKG_VERSION)
-PKG_MD5SUM:=db4a45a17104f10f3ee599d88267c9e5
+PKG_MD5SUM:=84fffe96b8537c81a463faccead80026
 
 PKG_BUILD_DEPENDS:=zlib
 
index ff748c8e41db01f2ff31af2fd8baa02d7857200e..993deef2a5f2c051339ac6cf01dc99f04f18e12a 100644 (file)
@@ -1,12 +1,11 @@
-diff -urN cups-1.3.7/Makefile cups-1.3.7.new/Makefile
---- cups-1.3.7/Makefile        2008-02-16 00:26:51.000000000 +0100
-+++ cups-1.3.7.new/Makefile    2008-07-13 16:46:01.000000000 +0200
-@@ -19,8 +19,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -19,8 +19,8 @@ include Makedefs
  # Directories to make...
  #
  
 -DIRS  =       cups backend berkeley cgi-bin filter locale man monitor \
--              notifier $(PDFTOPS) scheduler systemv test \
+-              notifier scheduler systemv test \
 +DIRS  =       cups backend berkeley cgi-bin filter monitor \
 +              notifier scheduler systemv \
                $(PHPDIR) \
index eceb8e9c0faff3cfebe3d2e6d7ba33bf958d1a68..f10fb1e027a8ec0c485f8d25dab5bc2c2b45a92d 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN cups-1.3.7/systemv/Makefile cups-1.3.7.new/systemv/Makefile
---- cups-1.3.7/systemv/Makefile        2007-07-11 23:46:42.000000000 +0200
-+++ cups-1.3.7.new/systemv/Makefile    2008-07-13 16:15:46.000000000 +0200
-@@ -70,7 +70,7 @@
+--- a/systemv/Makefile
++++ b/systemv/Makefile
+@@ -70,7 +70,7 @@ install:     all
        $(INSTALL_BIN) lp $(BINDIR)
        $(INSTALL_BIN) lpoptions $(BINDIR)
        $(INSTALL_BIN) lpstat $(BINDIR)
index 80b4d287117cf9518548a581947d20ba3bc38acb..dca3fcb47541f5afcade8b9f3dd78433074c80ab 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN cups-1.3.7/configure cups-1.3.7.new/configure
---- cups-1.3.7/configure       2008-04-01 23:59:43.000000000 +0200
-+++ cups-1.3.7.new/configure   2008-07-13 16:17:08.000000000 +0200
-@@ -1920,7 +1920,7 @@
+--- a/configure
++++ b/configure
+@@ -1926,7 +1926,7 @@ ac_compiler_gnu=$ac_cv_c_compiler_gnu
  
  
  
index b58cd30bcffbc7a966bf0c7e6db87e2280312a5e..bd6db199017c04c36f7a9af837ee6f82798b7c52 100644 (file)
@@ -1,6 +1,6 @@
---- cups-1.3.7/cups-config.in  2007-07-11 23:46:42.000000000 +0200
-+++ cups-1.3.7.new/cups-config.in      2008-07-13 17:17:00.000000000 +0200
-@@ -53,7 +53,7 @@
+--- a/cups-config.in
++++ b/cups-config.in
+@@ -53,7 +53,7 @@ else
        CFLAGS="$CFLAGS -I$includedir"
      fi
  
@@ -9,10 +9,9 @@
        LDFLAGS="$LDFLAGS -L$libdir"
      fi
  fi
-diff -urN cups-1.3.7/config-scripts/cups-3264.m4 cups-1.3.7.new/config-scripts/cups-3264.m4
---- cups-1.3.7/config-scripts/cups-3264.m4     2007-07-11 23:46:42.000000000 +0200
-+++ cups-1.3.7.new/config-scripts/cups-3264.m4 2008-07-13 17:21:36.000000000 +0200
-@@ -108,7 +108,7 @@
+--- a/config-scripts/cups-3264.m4
++++ b/config-scripts/cups-3264.m4
+@@ -108,7 +108,7 @@ case "$uname" in
                        LIB64CUPSIMAGE="64bit/libcupsimage.so.2"
                        LIB64DIR="$exec_prefix/lib"
                        if test -d /usr/lib64; then
@@ -21,10 +20,9 @@ diff -urN cups-1.3.7/config-scripts/cups-3264.m4 cups-1.3.7.new/config-scripts/c
                        fi
                        UNINSTALL64="uninstall64bit"
                fi
-diff -urN cups-1.3.7/config-scripts/cups-directories.m4 cups-1.3.7.new/config-scripts/cups-directories.m4
---- cups-1.3.7/config-scripts/cups-directories.m4      2007-09-18 22:39:31.000000000 +0200
-+++ cups-1.3.7.new/config-scripts/cups-directories.m4  2008-07-13 17:21:51.000000000 +0200
-@@ -107,7 +107,7 @@
+--- a/config-scripts/cups-directories.m4
++++ b/config-scripts/cups-directories.m4
+@@ -107,7 +107,7 @@ if test "$libdir" = "\${exec_prefix}/lib
                        ;;
                Linux*)
                        if test -d /usr/lib64; then
@@ -33,9 +31,9 @@ diff -urN cups-1.3.7/config-scripts/cups-directories.m4 cups-1.3.7.new/config-sc
                        fi
                        ;;
                HP-UX*)
---- cups-1.3.7/configure       2008-04-01 23:59:43.000000000 +0200
-+++ cups-1.3.7.new/configure   2008-07-13 17:20:19.000000000 +0200
-@@ -9217,7 +9217,7 @@
+--- a/configure
++++ b/configure
+@@ -9254,7 +9254,7 @@ if test "$libdir" = "\${exec_prefix}/lib
                        ;;
                Linux*)
                        if test -d /usr/lib64; then
@@ -44,7 +42,7 @@ diff -urN cups-1.3.7/config-scripts/cups-directories.m4 cups-1.3.7.new/config-sc
                        fi
                        ;;
                HP-UX*)
-@@ -9761,9 +9761,6 @@
+@@ -9792,9 +9792,6 @@ case "$uname" in
                        LIB32CUPS="32bit/libcups.so.2"
                        LIB32CUPSIMAGE="32bit/libcupsimage.so.2"
                        LIB32DIR="$exec_prefix/lib"
@@ -54,7 +52,7 @@ diff -urN cups-1.3.7/config-scripts/cups-directories.m4 cups-1.3.7.new/config-sc
                        UNINSTALL32="uninstall32bit"
                fi
  
-@@ -9773,9 +9770,6 @@
+@@ -9804,9 +9801,6 @@ case "$uname" in
                        LIB64CUPS="64bit/libcups.so.2"
                        LIB64CUPSIMAGE="64bit/libcupsimage.so.2"
                        LIB64DIR="$exec_prefix/lib"
index f26b7472eb1de9ec85bdece5ffb3365b39cbe606..6d5633a3955a7e988784dde41ef911f0df7a9084 100644 (file)
@@ -1,9 +1,9 @@
---- cups-1.3.7/configure.old   2008-10-19 23:29:10.000000000 +0200
-+++ cups-1.3.7/configure       2008-10-19 23:31:10.000000000 +0200
-@@ -10115,59 +10115,6 @@
+--- a/configure
++++ b/configure
+@@ -10146,59 +10146,6 @@ if test -n "$GCC"; then
                OPTIM="-fPIC $OPTIM"
        fi
-
 -      # The -fstack-protector option is available with some versions of
 -      # GCC and adds "stack canaries" which detect when the return address
 -      # has been overwritten, preventing many types of exploit attacks.