pwrtray: Make LCD dimming working properly
authorMichael Büsch <mb@bu3sch.de>
Sat, 11 Sep 2010 16:13:31 +0000 (16:13 +0000)
committerMichael Büsch <mb@bu3sch.de>
Sat, 11 Sep 2010 16:13:31 +0000 (16:13 +0000)
SVN-Revision: 23006

Xorg/app/pwrtray/Makefile
Xorg/app/pwrtray/files/etc/pwrtray-backendrc [new file with mode: 0644]

index f160ba0d4630280af7b9ae129ebe19278ff716b8..a576a1960517f117e0eb106b67a3dba395aeede3 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pwrtray
-PKG_REV:=e1cf5f9d31152a383612b2298f694894584127ab
+PKG_REV:=ca4cf695f80d5d1f221f64abddb7184aad1a08c0
 PKG_VERSION:=$(PKG_REV)
 PKG_RELEASE:=1
 
@@ -57,6 +57,8 @@ define Package/pwrtray/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray-backend $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/pwrtray $(1)/usr/share/
+       [ -e $(1)/etc/pwrtray-backendrc ] || \
+               $(INSTALL_DATA) ./files/etc/pwrtray-backendrc $(1)/etc/
 endef
 
 $(eval $(call BuildPackage,pwrtray))
diff --git a/Xorg/app/pwrtray/files/etc/pwrtray-backendrc b/Xorg/app/pwrtray/files/etc/pwrtray-backendrc
new file mode 100644 (file)
index 0000000..e471aae
--- /dev/null
@@ -0,0 +1,12 @@
+# pwrtray-backend configuration
+
+[BACKLIGHT]
+# List of auto-dimming steps.
+#   idle-seconds/brightness-percent idle-seconds/brightness-percent ...
+# idle-seconds value must be growing.
+autodim_steps=10/70 20/50 25/25 30/10 35/0
+# Maximum brightness value set by the autodimmer
+autodim_max=80
+# Enable auto-dimming by default?
+autodim_default_on=1
+