[package] comgt: add ACM hotplug
authorFlorian Fainelli <florian@openwrt.org>
Sun, 20 Feb 2011 17:24:25 +0000 (17:24 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 20 Feb 2011 17:24:25 +0000 (17:24 +0000)
This adds in support for ttyACM devices in the 3g hotplug script.

Signed-off-by: Matthew Eaton <wrt at divinehawk.com>
SVN-Revision: 25621

package/comgt/Makefile
package/comgt/files/3g.usb

index 5e36ad71c2f6e002d68f40cc67479db569f15582..c3cf8ed1b53a88830e0f6c44d1ce9f5169674411 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index c52646b3dde3a21d31185a78f89e7cb9b4652b99..ecaa96f85b153c584497d1467fcffb7b8a42006c 100644 (file)
@@ -36,8 +36,8 @@ if [ "$ACTION" = add ]; then
        esac
 
        local tty
-       for tty in /sys/$DEVPATH/ttyUSB*; do
-               [ -d "$tty" ] || break
+       for tty in /sys/$DEVPATH/ttyUSB* /sys/$DEVPATH/tty/ttyACM*;; do
+               [ -d "$tty" ] || continue
                config_foreach find_3g_iface interface "$tty"
        done
 fi