[packages] lsqlite3: fix compilation, set INCS & LIBS, pass UNAME to prevent it from...
authorNicolas Thill <nico@openwrt.org>
Fri, 26 Mar 2010 00:53:57 +0000 (00:53 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 26 Mar 2010 00:53:57 +0000 (00:53 +0000)
SVN-Revision: 20435

lang/lsqlite3/Makefile

index 6a4adcdf8c5fede61df837392c111568b97625a4..3a0ab5d346d5aec8f2c7ced831ebe5928e7065d6 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -39,13 +39,12 @@ TARGET_LDFLAGS += -llua
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               SQLITE3INC="$(STAGING_DIR)/usr/include/" \
-               SQLITE3LIB="$(STAGING_DIR)/usr/lib/" \
-               LUAINC="$(TARGET_CPPFLAGS)" \
-               LUALIB="$(TARGET_LDFLAGS)" \
-               LIBS="-shared $(TARGET_LDFLAGS)" \
-               CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
-               LD="$(TARGET_CROSS)ld -shared"
+               CC="$(TARGET_CC)" \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               INCS="$(TARGET_CPPFLAGS)" \
+               LIBS="$(TARGET_LDFLAGS)" \
+               SHFLAGS="-shared" \
+               UNAME="Linux" 
 endef
 
 define Package/lsqlite3/install