valgrind: set --enable-only64bit option for x86_64
authorJohn Crispin <john@openwrt.org>
Mon, 18 Aug 2014 13:10:19 +0000 (13:10 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 18 Aug 2014 13:10:19 +0000 (13:10 +0000)
There does not seem to be a good reason to build both
when building for x86_64.

SVN-Revision: 42198

package/devel/valgrind/Makefile

index 45d0323dbc3d398e33f7b7d54956d70c1f63b9ae..26dcf0b5c98cf27d68ce8db91cbdb01f945d78d6 100644 (file)
@@ -83,6 +83,8 @@ CONFIGURE_VARS += \
        UNAME_R=$(LINUX_VERSION)
 
 ifeq ($(ARCH),x86_64)
        UNAME_R=$(LINUX_VERSION)
 
 ifeq ($(ARCH),x86_64)
+       CONFIGURE_ARGS += \
+               --enable-only64bit
        BITS := 64bit
 else
        CONFIGURE_ARGS += \
        BITS := 64bit
 else
        CONFIGURE_ARGS += \