[package] kernel: make xen pcidev driver depend on Linux 2.6.37 or 2.6.38
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 23 Feb 2011 21:43:50 +0000 (21:43 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 23 Feb 2011 21:43:50 +0000 (21:43 +0000)
SVN-Revision: 25669

package/kernel/modules/virtual.mk

index 67e04a0..c4604bc 100644 (file)
@@ -166,7 +166,7 @@ $(eval $(call KernelPackage,xen-netdev))
 define KernelPackage/xen-pcidev
   SUBMENU:=$(VIRTUAL_MENU)
   TITLE:=Xen PCI device frontend
-  DEPENDS:=@TARGET_x86_xen_domu
+  DEPENDS:=@TARGET_x86_xen_domu @LINUX_2_6_37||LINUX_2_6_38
   KCONFIG:=CONFIG_XEN_PCIDEV_FRONTEND
   FILES:=$(LINUX_DIR)/drivers/net/xen-pcifront.ko
   AUTOLOAD:=$(call AutoLoad,10,xen-pcifront)