[kernel] generic-2.6/2.6.30: refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Fri, 22 May 2009 09:46:02 +0000 (09:46 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 22 May 2009 09:46:02 +0000 (09:46 +0000)
SVN-Revision: 15981

target/linux/generic-2.6/patches-2.6.30/051-squashfs_pcomp.patch
target/linux/generic-2.6/patches-2.6.30/052-pcomp_lzma_support.patch
target/linux/generic-2.6/patches-2.6.30/053-squashfs_lzma.patch
target/linux/generic-2.6/patches-2.6.30/970-ocf_kbuild_integration.patch

index 271c4e5c8b762dd8e4ac08155325913c900831d6..fc2a731ddeb46dfab1447b980d8f282498de01df 100644 (file)
                goto failure;
        }
  
-@@ -284,17 +311,18 @@ failed_mount:
+@@ -294,17 +321,18 @@ failed_mount:
        kfree(msblk->inode_lookup_table);
        kfree(msblk->fragment_index);
        kfree(msblk->id_table);
  }
  
  
-@@ -333,7 +361,7 @@ static void squashfs_put_super(struct su
+@@ -346,7 +374,7 @@ static void squashfs_put_super(struct su
                kfree(sbi->id_table);
                kfree(sbi->fragment_index);
                kfree(sbi->meta_index);
index c5265e9b2953c17104a71137476c7e969cf7bfe3..3259db40a8c0ef756aa9e818cd733815d4be68cf 100644 (file)
 +MODULE_AUTHOR("Felix Fietkau <nbd@openwrt.org>");
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -728,6 +728,12 @@ config CRYPTO_ZLIB
+@@ -758,6 +758,12 @@ config CRYPTO_ZLIB
        help
          This is the zlib algorithm.
  
        select CRYPTO_ALGAPI
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -73,6 +73,7 @@ obj-$(CONFIG_CRYPTO_SEED) += seed.o
+@@ -75,6 +75,7 @@ obj-$(CONFIG_CRYPTO_SEED) += seed.o
  obj-$(CONFIG_CRYPTO_SALSA20) += salsa20_generic.o
  obj-$(CONFIG_CRYPTO_DEFLATE) += deflate.o
  obj-$(CONFIG_CRYPTO_ZLIB) += zlib.o
index b632e0592668ec8217c9ebda8f13d64681d59248..aea4aced709a8fbd184e8edfaa8ab9d038333819 100644 (file)
        if (err < 0)
                goto failed_mount;
  
-@@ -305,21 +342,16 @@ allocate_root:
+@@ -315,21 +352,16 @@ allocate_root:
        return 0;
  
  failed_mount:
index b24d59cfff23f414bea582d45f8cb6b42bceadff..bf229eab8256a6ecb696ab285892048cb6dbea29 100644 (file)
@@ -1,6 +1,6 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -778,6 +778,8 @@ config CRYPTO_ANSI_CPRNG
+@@ -784,6 +784,8 @@ config CRYPTO_ANSI_CPRNG
          for cryptographic modules.  Uses the Algorithm specified in
          ANSI X9.31 A.2.4
  
@@ -11,7 +11,7 @@
  endif # if CRYPTO
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -85,6 +85,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
  obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
  
  #