lantiq: remove the useless ltqtapi.mk include file
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 18:58:47 +0000 (18:58 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Oct 2014 18:58:47 +0000 (18:58 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 42778

include/ltqtapi.mk [deleted file]
package/kernel/lantiq/ltq-tapi/Makefile
package/kernel/lantiq/ltq-vmmc/Makefile

diff --git a/include/ltqtapi.mk b/include/ltqtapi.mk
deleted file mode 100644 (file)
index f4d06ad..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-LTQ_TAPI_BUILD_DEPENDS:=TARGET_lantiq_xway:kmod-ltq-tapi \
-       TARGET_lantiq_xway:kmod-ltq-vmmc \
-       TARGET_lantiq_falcon:kmod-ltq-tapi \
-       TARGET_lantiq_falcon:kmod-ltq-vmmc
-
-LTQ_TAPI_TARGET:=@(TARGET_lantiq_falcon||TARGET_lantiq_xway)
-
-LTQ_TAPI_DEPENDS:=$(LTQ_TAPI_TARGET) \
-       +TARGET_lantiq_xway:kmod-ltq-tapi \
-       +TARGET_lantiq_xway:kmod-ltq-vmmc \
-       +TARGET_lantiq_falcon:kmod-ltq-tapi \
-       +TARGET_lantiq_falcon:kmod-ltq-vmmc
index e0742e63e52de80a8d6724c82081f64e81dcff94..0b4301c50ebe27ecbcc9bca68ca952816b2898fa 100644 (file)
@@ -20,14 +20,13 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 PKG_USE_MIPS16:=0
 PKG_CHECK_FORMAT_SECURITY:=0
 
-include $(INCLUDE_DIR)/ltqtapi.mk
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/ltq-tapi
   SUBMENU:=Voice over IP
   TITLE:=Lantiq TAPI subsystem
   URL:=http://www.lantiq.com/
-  DEPENDS:=$(LTQ_TAPI_TARGET) +kmod-ltq-ifxos
+  DEPENDS:=@(TARGET_lantiq_falcon||TARGET_lantiq_xway) +kmod-ltq-ifxos
   FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
   AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
 endef
index d25f3e14b2911c994bd65ebd1ae91cbeffd003e5..df97fa19eee4e12bf7eda04f8fce123088a723ba 100644 (file)
@@ -20,14 +20,13 @@ PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
 PKG_USE_MIPS16:=0
 PKG_CHECK_FORMAT_SECURITY:=0
 
-include $(INCLUDE_DIR)/ltqtapi.mk
 include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/ltq-vmmc
   SUBMENU:=Voice over IP
   TITLE:=TAPI LL driver for Voice Macro
   URL:=http://www.lantiq.com/
-  DEPENDS:=$(LTQ_TAPI_TARGET) +kmod-ltq-tapi
+  DEPENDS:=@(TARGET_lantiq_falcon||TARGET_lantiq_xway) +kmod-ltq-tapi
   FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.ko
   AUTOLOAD:=$(call AutoProbe,drv_vmmc)
 endef