fix a small bug in the config merge/split (fixes buildbot error on ixp4xx)
authorFelix Fietkau <nbd@openwrt.org>
Wed, 28 Feb 2007 13:00:26 +0000 (13:00 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 28 Feb 2007 13:00:26 +0000 (13:00 +0000)
SVN-Revision: 6427

scripts/config.pl
target/linux/ixp4xx-2.6/config/default

index dcebfe6..2f4a968 100755 (executable)
@@ -23,7 +23,7 @@ sub load_config($) {
                        next;
                };
                /^# CONFIG_(.+?) is not set/ and do {
-                       $config{$1} = -1;
+                       $config{$1} = "#undef";
                        next;
                };
                /^#/ and next;
@@ -91,7 +91,7 @@ sub config_sub($$) {
 sub print_cfgline($$) {
        my $name = shift;
        my $val = shift;
-       if ($val eq '-1') {
+       if ($val eq '#undef') {
                print "# CONFIG_$name is not set\n";
        } else {
                print "CONFIG_$name=$val\n";
index 9336723..7c9fec0 100644 (file)
@@ -265,7 +265,7 @@ CONFIG_MTD_PARTITIONS=y
 # CONFIG_MTD_PLATRAM is not set
 # CONFIG_MTD_PMC551 is not set
 # CONFIG_MTD_RAM is not set
-# CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK is not set
+CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
 CONFIG_MTD_REDBOOT_PARTS=y
 CONFIG_MTD_REDBOOT_PARTS_READONLY=y
 CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED=y
@@ -331,7 +331,6 @@ CONFIG_PATA_ARTOP=m
 # CONFIG_PATA_VIA is not set
 # CONFIG_PATA_WINBOND is not set
 # CONFIG_PC300 is not set
-# CONFIG_PCMCIA is not set
 # CONFIG_PCCARD is not set
 # CONFIG_PCI200SYN is not set
 # CONFIG_PCIPCWATCHDOG is not set