add prereq checks for target/linux/* and target/image/*, check for fdisk for the...
authorFelix Fietkau <nbd@openwrt.org>
Sat, 18 Nov 2006 21:12:18 +0000 (21:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 18 Nov 2006 21:12:18 +0000 (21:12 +0000)
SVN-Revision: 5569

Makefile
include/image.mk
include/kernel-build.mk
target/Makefile
target/image/x86/Makefile
target/linux/x86-2.6/Makefile

index eed9335a5be66ba6f5d657f9d775d49f4f7bd6cf..3551a64151c81b5847a30ea0394c885a244a6759 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -49,7 +49,7 @@ endif
 
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
 
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
-  world: tmp/.prereq-packages
+  world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
 tmp/.pkginfo:
 endif
 
 tmp/.pkginfo:
@@ -133,8 +133,16 @@ tmp/.prereq-packages: include/prereq.mk tmp/.pkginfo .config
                false; \
        }
        @touch $@
                false; \
        }
        @touch $@
-       
-prereq: tmp/.prereq-build tmp/.prereq-packages FORCE
+
+tmp/.prereq-target: include/prereq.mk tmp/.targetinfo .config
+       @mkdir -p tmp
+       @$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: tmp/.prereq-build tmp/.prereq-packages tmp/.prereq-target FORCE
 
 download: .config FORCE
        $(MAKE) tools/download
 
 download: .config FORCE
        $(MAKE) tools/download
index 6805389d72529197c8bf5d98889fedb8a7abd46c..70677b9c2f2f4e48ff0602e6bdf425b7c46cf937 100644 (file)
@@ -5,6 +5,7 @@
 # See /LICENSE for more information.
 #
 
 # See /LICENSE for more information.
 #
 
+include $(INCLUDE_DIR)/prereq.mk
 include $(INCLUDE_DIR)/kernel.mk
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
 include $(INCLUDE_DIR)/kernel.mk
 KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
 
index 35149d768614eda67148b661a6a9744cf6b95b33..4967dfb67e1f045ae1f0bd6a841ebd020dd2f1fc 100644 (file)
@@ -6,6 +6,8 @@
 #
 KERNEL_BUILD:=1
 
 #
 KERNEL_BUILD:=1
 
+include $(INCLUDE_DIR)/prereq.mk
+
 # For target profile selection - the default set
 DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd
 
 # For target profile selection - the default set
 DEFAULT_PACKAGES:=base-files libgcc uclibc bridge busybox dnsmasq dropbear iptables mtd ppp ppp-mod-pppoe mtd
 
index dc21033e5f6bd04caed4d04657f7e77c364614b8..c00eea0d66fa838ff0eabd4edde47b3594aaa9f5 100644 (file)
@@ -25,6 +25,10 @@ compile: linux-compile image_compile
 install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
 clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
 
 install: image_clean $(patsubst %,%-install,$(TARGETS-y)) image_install
 clean: $(patsubst %,%-clean,$(TARGETS-y)) image_clean
 
+prereq: FORCE
+       $(MAKE) -C linux/$(BOARD)-$(KERNEL) prereq
+       $(MAKE) -C image/$(BOARD) prereq
+
 image_clean: FORCE
        $(MAKE) -C image/$(BOARD) clean
        rm -f $(BIN_DIR)/openwrt-*
 image_clean: FORCE
        $(MAKE) -C image/$(BOARD) clean
        rm -f $(BIN_DIR)/openwrt-*
index adace07dc42970c13697f8e19e2ed7e35caf63f2..d3bbe045be067b5609b2c3479c52d6b68f71fb15 100644 (file)
@@ -54,5 +54,8 @@ define Image/Build
        cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
 endef
 
        cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
 endef
 
-
 $(eval $(call BuildImage))
 $(eval $(call BuildImage))
+
+$(eval $(call RequireCommand,fdisk, \
+       Please install fdisk \
+))
index 77912e6fb91452268a3462d22fcf3cd6b139d342..8676aab8cfa2411e980601831b90e8bcd5b5c1cc 100644 (file)
@@ -16,4 +16,6 @@ LINUX_RELEASE:=1
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
 LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
 
 include $(INCLUDE_DIR)/kernel-build.mk
+
 $(eval $(call BuildKernel))
 $(eval $(call BuildKernel))
+