build: make mkfs-* depend on kernel installation to fix parallel build issues
authorFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 22:01:27 +0000 (22:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 22:01:27 +0000 (22:01 +0000)
Reported-by: Petr Štetiar <ynezz@true.cz>
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47296

include/image.mk

index c59222e415fb56e279e76e08d883179f54ac753a..4e22fa59a0f2f76c2778010e80238699608e8824 100644 (file)
@@ -282,7 +282,7 @@ endef
 define BuildImage/mkfs
   install: mkfs-$(1)
   .PHONY: mkfs-$(1)
-  mkfs-$(1): mkfs_prepare
+  mkfs-$(1): kernel_prepare
        $(Image/mkfs/$(1))
        $(call Build/mkfs/default,$(1))
        $(call Build/mkfs/$(1),$(1))