make the lzma version kernel version dependent, and only build the one we do need
authorImre Kaloz <kaloz@openwrt.org>
Sun, 15 Nov 2009 20:25:29 +0000 (20:25 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Sun, 15 Nov 2009 20:25:29 +0000 (20:25 +0000)
SVN-Revision: 18426

tools/Makefile
tools/lzma/Makefile

index b7c7f43db6f98ce253d6430684587ffe72d618de..e3e26f3c4ff04eb4fe7a04bb49ff9054f43246ed 100644 (file)
@@ -14,11 +14,15 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
 tools-y += m4 autoconf automake bison pkg-config sed mklibs
-tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
+tools-y += sstrip ipkg-utils genext2fs mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
+ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_21)$(CONFIG_LINUX_2_6_25)$(CONFIG_LINUX_2_6_28),)
+tools-y += squashfs lzma-old 
+else
+tools-y += squashfs4 lzma
+endif
 
 tools-$(CONFIG_CCACHE) += ccache
-tools-dep += lzma
 
 ifdef CONFIG_GCC_USE_GRAPHITE
   tools-y += ppl cloog
index bebfbafd57f78462237eae7704882cae73172608..b39c8627ecc14b8f2213e24b9e5152572d874aa6 100644 (file)
@@ -27,6 +27,7 @@ endef
 
 define Host/Install
        $(INSTALL_DIR) $(STAGING_DIR_HOST)/lib $(STAGING_DIR_HOST)/include $(STAGING_DIR_HOST)/bin
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/CPP/7zip/Compress/LZMA_Alone/lzma_alone $(STAGING_DIR_HOST)/bin/lzma
        $(CP) $(HOST_BUILD_DIR)/C/*.h $(STAGING_DIR_HOST)/include/
        $(CP) $(UTIL_DIR)/liblzma.a $(STAGING_DIR_HOST)/lib/
 endef