package wlcompat
authorFelix Fietkau <nbd@openwrt.org>
Tue, 12 Apr 2005 17:05:52 +0000 (17:05 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 12 Apr 2005 17:05:52 +0000 (17:05 +0000)
SVN-Revision: 637

openwrt/package/openwrt/Makefile
openwrt/package/openwrt/kmod-wlcompat.control [new file with mode: 0644]
openwrt/package/openwrt/wlcompat.c

index 1580c13a91ef0f3cabaf9cd32c095f82b55af23a..a5642cd4e768900703229ac9f5712a0edebe4dab 100644 (file)
@@ -8,6 +8,8 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_RELEASE)_$(ARCH).ipk
 PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
+PKG_WLCOMPAT := $(PACKAGE_DIR)/kmod-wlcompat_$(LINUX_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+
 SHARED_INCLUDE:=${shell pwd}/include
 
 libshared-compile libnvram-compile:
@@ -62,14 +64,36 @@ $(PKG_IPK): $(PKG_IPK_DIR)/sbin/mtd $(PKG_IPK_DIR)/sbin/jffs2root $(PKG_IPK_DIR)
        $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
 
 $(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
+       $(IPKG) install $<
+
+$(IPKG_STATE_DIR)/info/kmod-wlcompat.list: $(PKG_WLCOMPAT)
+       $(IPKG) install $<
+
+
+WLCOMPAT_FLAGS:=$(TARGET_CLFAGS) -D__KERNEL__ -fno-strict-aliasing -fno-common -fomit-frame-pointer -G 0 \
+               -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 \
+               -Wa,-mips32 -Wa,--trap -DMODULE -mlong-calls -fno-common -I. -I linux-2.4 -funsigned-char -nostdinc \
+               -iwithprefix include -I$(LINUX_DIR)/include -I$(LINUX_DIR)/include/asm/gcc -I./include -c
+               
+$(PKG_BUILD_DIR)/wlcompat.o:
+       $(TARGET_CC) $(WLCOMPAT_FLAGS) -o $@ wlcompat.c
+
+$(PKG_BUILD_DIR)/wlcompat-debug.o:
+       $(TARGET_CC) -DDEBUG $(WLCOMPAT_FLAGS) -o $@ wlcompat.c
+
+$(PKG_WLCOMPAT): $(PKG_BUILD_DIR)/wlcompat.o $(PKG_BUILD_DIR)/wlcompat-debug.o
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_BUILD_DIR)/wlcompat kmod-wlcompat.control $(LINUX_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)
+       cp $^ $(PKG_BUILD_DIR)/wlcompat/lib/modules/$(LINUX_VERSION)/
+       $(IPKG_BUILD) $(PKG_BUILD_DIR)/wlcompat $(PACKAGE_DIR)
 
 source: $(DL_DIR)/$(LINKSYS_WLCONF_TGZ)
 prepare: $(LINKSYS_WLCONF_DIR)/.unpacked
-compile: prepare libnvram-compile libshared-compile $(PKG_IPK)
+compile: prepare libnvram-compile libshared-compile $(PKG_IPK) $(PKG_WLCOMPAT)
 install: libnvram-install libshared-install \
         $(TARGET_DIR)/usr/sbin/wlconf \
-        $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+        $(IPKG_STATE_DIR)/info/$(PKG_NAME).list \
+        $(IPKG_STATE_DIR)/info/kmod-wlcompat.list
 
 clean: libshared-clean libnvram-clean
        rm -rf $(PKG_BUILD_DIR)
diff --git a/openwrt/package/openwrt/kmod-wlcompat.control b/openwrt/package/openwrt/kmod-wlcompat.control
new file mode 100644 (file)
index 0000000..8891fb4
--- /dev/null
@@ -0,0 +1,7 @@
+Package: kmod-wlcompat
+Priority: optional
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: kmod-brcm-wl
+Description: Compatibility module for using the Wireless Extension with broadcom's wl
index 13165523daaf5f8007ac513b970306860c11889c..3f2f407631387606dd697f1be99065e76ceda2c6 100644 (file)
@@ -32,8 +32,6 @@
 #include <net/iw_handler.h>
 #include <wlioctl.h>
 
-#define DEBUG
-
 static struct net_device *dev;
 char buf[WLC_IOCTL_MAXLEN];