host.mk: Don't use bash-ism
authorMichael Büsch <mb@bu3sch.de>
Mon, 6 Sep 2010 21:22:54 +0000 (21:22 +0000)
committerMichael Büsch <mb@bu3sch.de>
Mon, 6 Sep 2010 21:22:54 +0000 (21:22 +0000)
SVN-Revision: 22963

include/host.mk

index 8092e8db77ac74e1f07c2c1ab1e15b7f1a9a30b4..f3e47c8723c452218968c7b8d2b7843a97e89acc 100644 (file)
@@ -36,7 +36,7 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                        *) HOST_ARCH=`uname -p`;; \
                esac; \
                GNU_HOST_NAME=`gcc -dumpmachine`; \
-               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" == "Darwin" ] && \
+               [ -z "$$GNU_HOST_NAME" -o "$$HOST_OS" = "Darwin" ] && \
                        GNU_HOST_NAME=`$(TOPDIR)/scripts/config.guess`; \
                echo "HOST_OS:=$$HOST_OS" > $@; \
                echo "HOST_ARCH:=$$HOST_ARCH" >> $@; \