add libtool fixes, cleanup
authorNicolas Thill <nico@openwrt.org>
Sat, 22 Sep 2007 15:44:29 +0000 (15:44 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 22 Sep 2007 15:44:29 +0000 (15:44 +0000)
SVN-Revision: 8951

libs/libosip2/Makefile

index b281a0bc58174eb8007d378a7976f7a42cf5e1e6..4d579295a75f4e4c5eaf6b4376873c4d33ba53cd 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006,2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,39 +15,39 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/osip
 PKG_MD5SUM:=f1237af0250c59b318bd64a59f5750ea
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/osip
 PKG_MD5SUM:=f1237af0250c59b318bd64a59f5750ea
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libosip2
   SECTION:=libs
   CATEGORY:=Libraries
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libosip2
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+libpthread
-  TITLE:=The GNU oSIP library
-  DESCRIPTION:=\
-       GNU oSIP library, a Session Initiation Protocol (SIP) implementation.
+  TITLE:=GNU oSIP library
   URL:=http://www.gnu.org/software/osip/
   URL:=http://www.gnu.org/software/osip/
+  DEPENDS:=+libpthread
 endef
 
 endef
 
+define Package/libosip2description
+ GNU oSIP library, a Session Initiation Protocol (SIP) implementation.
+endef
+
+CONFIGURE_ARGS+= \
+       --enable-shared \
+       --enable-static \
+       --disable-debug \
+       --disable-trace \
+       --enable-pthread \
+       --enable-semaphore \
+       --enable-ntimer \
+
 define Build/Configure
 define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-shared \
-               --enable-static \
-               --disable-debug \
-               --disable-trace \
-               --enable-pthread \
-               --enable-semaphore \
-               --enable-ntimer \
-       )
+       $(call Build/Configure/Default)
+       $(call libtool_disable_rpath)
 endef
 
 define Build/Compile
 endef
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
+       $(MAKE) -C $(PKG_BUILD_DIR) all
+       $(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
+       $(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
@@ -60,8 +60,7 @@ define Build/InstallDev
 endef
 
 define Build/UninstallDev
 endef
 
 define Build/UninstallDev
-       rm -rf \
-               $(STAGING_DIR)/usr/include/osip{,parser}2 \
+       rm -rf  $(STAGING_DIR)/usr/include/osip{,parser}2 \
                $(STAGING_DIR)/usr/lib/libosip{,parser}2.{a,so*} \
                $(STAGING_DIR)/usr/lib/pkgconfig/libosip2.pc
 endef
                $(STAGING_DIR)/usr/lib/libosip{,parser}2.{a,so*} \
                $(STAGING_DIR)/usr/lib/pkgconfig/libosip2.pc
 endef