[kernel] Add INA2XX current sensor module.
authorJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:00:44 +0000 (10:00 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 3 Apr 2013 10:00:44 +0000 (10:00 +0000)
This is a I2C current/voltage/power sensor.

Signed-off-by: Tobias Diedrich <ranma+openwrt@tdiedrich.de>
SVN-Revision: 36182

package/kernel/modules/hwmon.mk

index bc1f65281da19b22f30e21ce5e2a180040a2f81e..969e8fa3aa7d503e27cc669841c59aa22def55f0 100644 (file)
@@ -60,6 +60,21 @@ endef
 $(eval $(call KernelPackage,hwmon-adt7475))
 
 
 $(eval $(call KernelPackage,hwmon-adt7475))
 
 
+define KernelPackage/hwmon-ina2xx
+  TITLE:=INA2XX monitoring support
+  KCONFIG:=CONFIG_SENSORS_INA2XX
+  FILES:=$(LINUX_DIR)/drivers/hwmon/ina2xx.ko
+  AUTOLOAD:=$(call AutoLoad,60,ina2xx)
+  $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-ina2xx/description
+ Kernel module for ina2xx dc current monitor chips
+endef
+
+$(eval $(call KernelPackage,hwmon-ina2xx))
+
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63