[backfire] let the libtool fixup introduce libltdl and libiconv build depends, as...
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Dec 2010 05:19:48 +0000 (05:19 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Dec 2010 05:19:48 +0000 (05:19 +0000)
SVN-Revision: 24714

include/autotools.mk

index b89d287c39207a4fa9f7de9794c997e7ec1b8f0b..68b5835e97c0e1c7340cdbe7481ee4bc1472d2d9 100644 (file)
@@ -69,14 +69,14 @@ ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
 endif
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
   Hooks/Configure/Pre += update_libtool remove_version_check
   Hooks/Configure/Post += update_libtool
   Hooks/InstallDev/Post += libtool_fixup_libdir
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool libintl libiconv
   Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
   Hooks/Configure/Post += update_libtool_ucxx
   Hooks/InstallDev/Post += libtool_fixup_libdir