rename wl.o wireless interface from ethX to wl0
authorFelix Fietkau <nbd@openwrt.org>
Sat, 6 May 2006 02:34:35 +0000 (02:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 6 May 2006 02:34:35 +0000 (02:34 +0000)
SVN-Revision: 3732

openwrt/target/linux/brcm-2.4/patches/001-bcm47xx.patch
openwrt/target/linux/package/base-files/files/brcm-2.4/etc/hotplug.d/net/09-net
openwrt/target/linux/package/wlcompat/wlcompat.c

index b83db3504369dbbbca25f0e61c6e738f09da26b3..8ed9f0b43b5f2f292ce2c0cda58a3f1740346747 100644 (file)
@@ -16339,7 +16339,7 @@ diff -urN linux.old/drivers/net/wireless/Config.in linux.dev/drivers/net/wireles
 diff -urN linux.old/drivers/net/wl/Makefile linux.dev/drivers/net/wl/Makefile
 --- linux.old/drivers/net/wl/Makefile  1970-01-01 01:00:00.000000000 +0100
 +++ linux.dev/drivers/net/wl/Makefile  2006-04-28 01:33:52.000000000 +0200
 diff -urN linux.old/drivers/net/wl/Makefile linux.dev/drivers/net/wl/Makefile
 --- linux.old/drivers/net/wl/Makefile  1970-01-01 01:00:00.000000000 +0100
 +++ linux.dev/drivers/net/wl/Makefile  2006-04-28 01:33:52.000000000 +0200
-@@ -0,0 +1,23 @@
+@@ -0,0 +1,26 @@
 +#
 +# Makefile for the Broadcom wl driver
 +#
 +#
 +# Makefile for the Broadcom wl driver
 +#
@@ -16357,11 +16357,14 @@ diff -urN linux.old/drivers/net/wl/Makefile linux.dev/drivers/net/wl/Makefile
 +
 +O_TARGET      := wl.o
 +
 +
 +O_TARGET      := wl.o
 +
-+obj-y         := wl_apsta.o
++obj-y         := wl_mod.o
 +obj-y         += bcmutils.o hnddma.o linux_osl.o
 +
 +obj-m         := $(O_TARGET)
 +
 +obj-y         += bcmutils.o hnddma.o linux_osl.o
 +
 +obj-m         := $(O_TARGET)
 +
++wl_mod.o: wl_apsta.o
++      sed -e 's,eth%d,wl%d\x00,g' < $< > $@
++
 +include $(TOPDIR)/Rules.make
 diff -urN linux.old/drivers/net/wl/bcmip.h linux.dev/drivers/net/wl/bcmip.h
 --- linux.old/drivers/net/wl/bcmip.h   1970-01-01 01:00:00.000000000 +0100
 +include $(TOPDIR)/Rules.make
 diff -urN linux.old/drivers/net/wl/bcmip.h linux.dev/drivers/net/wl/bcmip.h
 --- linux.old/drivers/net/wl/bcmip.h   1970-01-01 01:00:00.000000000 +0100
index 856d26b653b5b998659293b9535d634cac1144ea..9dd77963ba9e6a43157f78ef79a8c54301659161 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh
 #!/bin/sh
-setup_eth()
+setup_wl()
 {
        [ -f /proc/net/wl0 ] && {
                lsmod | grep wlcompat >&- || insmod wlcompat
 {
        [ -f /proc/net/wl0 ] && {
                lsmod | grep wlcompat >&- || insmod wlcompat
@@ -7,6 +7,9 @@ setup_eth()
        iwconfig "$INTERFACE" 2>&- | grep -v 'no wireless' >&- && {
                /sbin/wifi
        }
        iwconfig "$INTERFACE" 2>&- | grep -v 'no wireless' >&- && {
                /sbin/wifi
        }
+}
+setup_eth()
+{
        [ -d /proc/switch ] || {
                insmod switch-core
                insmod switch-robo || insmod switch-adm
        [ -d /proc/switch ] || {
                insmod switch-core
                insmod switch-robo || insmod switch-adm
@@ -30,6 +33,7 @@ do_register()
 {
        case "${INTERFACE%%[0-9]*}" in
                eth) setup_eth;;
 {
        case "${INTERFACE%%[0-9]*}" in
                eth) setup_eth;;
+               wl) setup_wl;;
        esac
 }
 
        esac
 }
 
index 7063c809a6bd4462aa0923ea19df6e8a0e4b62e4..1540a211676bafa84780412fc397a4d015924168 100644 (file)
@@ -980,13 +980,13 @@ static int new_ioctl(struct net_device *dev, struct ifreq *ifr, int cmd) {
 static int __init wlcompat_init()
 {
        int found = 0, i;
 static int __init wlcompat_init()
 {
        int found = 0, i;
-       char *devname = "eth0";
+       char devname[4] = "wl0";
        bss_force = 0;
        
        while (!found && (dev = dev_get_by_name(devname))) {
                if ((dev->wireless_handlers == NULL) && ((wl_ioctl(dev, WLC_GET_MAGIC, &i, sizeof(i)) == 0) && i == WLC_IOCTL_MAGIC))
                        found = 1;
        bss_force = 0;
        
        while (!found && (dev = dev_get_by_name(devname))) {
                if ((dev->wireless_handlers == NULL) && ((wl_ioctl(dev, WLC_GET_MAGIC, &i, sizeof(i)) == 0) && i == WLC_IOCTL_MAGIC))
                        found = 1;
-               devname[3]++;
+               devname[2]++;
        }
        
        if (!found) {
        }
        
        if (!found) {