packages/howl: use new service functions
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:25:17 +0000 (23:25 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 23:25:17 +0000 (23:25 +0000)
SVN-Revision: 28904

libs/howl/Makefile
libs/howl/files/autoipd.init
libs/howl/files/mDNSResponder.init
libs/howl/files/nifd.init

index 459f83834f93e8eaafebfd5250841632c19d5490..c21b7a8ffa54c202f5b6c1ee7a3bd3cfcb9509e5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=howl
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.porchdogsoft.com/download/
@@ -117,7 +117,7 @@ define Package/howl-autoipd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/autoipd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/autoipd.init $(1)/etc/init.d/autoipd
+       $(INSTALL_BIN) ./files/autoipd.init $(1)/etc/init.d/autoipd
 endef
 
 define Package/howl-mdnsresponder/install
@@ -133,7 +133,7 @@ define Package/howl-nifd/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/nifd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_DATA) ./files/nifd.init $(1)/etc/init.d/nifd
+       $(INSTALL_BIN) ./files/nifd.init $(1)/etc/init.d/nifd
 endef
 
 define Package/howl-utils/install
index e68ee776c43150233a1d7eb2b3a371d797b1aea8..4a8ec07d46f8b45ed0494b501c6724ed31ddaac8 100644 (file)
@@ -1,18 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-DEFAULT=/etc/default/autopid
-RUN_D=/var/run
-PID_F=$RUN_D/autoipd.pid
+# XXX: pid-file is /var/run/autoipd-<INTERFACE>.pid
+SERVICE_USE_PID=
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       autoipd $OPTIONS
+       service_start /usr/sbin/autoipd
 }
-
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/autoipd
 }
 
index a1f65084f5be46ccb6e824dc5213e584fda69505..d43fdb5d79ad999720837c251ab410296cbff71e 100644 (file)
@@ -1,17 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-DEFAULT=/etc/default/mDNSResponder
-RUN_D=/var/run
-PID_F=$RUN_D/mDNSResponder.pid
+SERVICE_USE_PID=1
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       mDNSResponder $OPTIONS
+       service_start /usr/sbin/mDNSResponder
 }
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/mDNSResponder
 }
 
index d650648e5439070f70f6406e4ca1d7f409f1c2d5..376eaaf7f2c2287705c28495e3e210d4dcba4d50 100644 (file)
@@ -1,17 +1,14 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
+
 START=50
 
-DEFAULT=/etc/default/nifd
-RUN_D=/var/run
-PID_F=$RUN_D/nifd.pid
+SERVICE_USE_PID=1
 
 start() {
-       [ -f $DEFAULT ] && . $DEFAULT
-       [ -d $RUN_D ] || mkdir -p $RUN_D
-       nifd $OPTIONS
+       service_start /usr/sbin/nifd
 }
 stop() {
-       [ -f $PID_F ] && kill $(cat $PID_F)
+       service_stop /usr/sbin/nifd
 }