uqmi: Add qmi.sh executable bit and fix option dhcp
authorFelix Fietkau <nbd@openwrt.org>
Mon, 21 Sep 2015 17:40:59 +0000 (17:40 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 21 Sep 2015 17:40:59 +0000 (17:40 +0000)
Using protocol qmi does not work since qmi.sh is not executable.
Setting option dhcp explicitely to 0 actually enables it.
This patch fixes both problems.

Signed-off-by: Matti Laakso <malaakso@elisanet.fi>
SVN-Revision: 47014

package/network/utils/uqmi/Makefile
package/network/utils/uqmi/files/lib/netifd/proto/qmi.sh [changed mode: 0644->0755]

index 16e7fea0a94c9ac40b72b9018b5cc0ca440b0e03..7ccf549989e30d3592c60a8ef6dae3ed5e74415a 100644 (file)
@@ -1,7 +1,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uqmi
-PKG_VERSION:=2015-08-13
+PKG_VERSION:=2015-09-17
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
old mode 100644 (file)
new mode 100755 (executable)
index 8ee7dbd..48864be
@@ -140,7 +140,7 @@ proto_qmi_setup() {
                return 1
        }
 
-       if [ -z "$dhcp" ]; then
+       if [ -z "$dhcp" -o "$dhcp" = 0 ]; then
                echo "Setting up $ifname"
                [ -n "$ipv4" ] && {
                        json_load "$(uqmi -s -d $device --set-client-id wds,$cid_4 --get-current-settings)"