adds gstreamer and basic plugins
authorJohn Crispin <john@openwrt.org>
Tue, 3 Jun 2008 20:46:25 +0000 (20:46 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 3 Jun 2008 20:46:25 +0000 (20:46 +0000)
SVN-Revision: 11345

multimedia/gst-plugins-base/Makefile [new file with mode: 0644]
multimedia/gstreamer/Makefile [new file with mode: 0644]

diff --git a/multimedia/gst-plugins-base/Makefile b/multimedia/gst-plugins-base/Makefile
new file mode 100644 (file)
index 0000000..a62d691
--- /dev/null
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gst-plugins-base
+PKG_VERSION:=0.10.12
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-base/
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+EXTRA_CFLAGS+= -I$(STAGING_DIR)/usr/lib/libintl/include/ -I$(STAGING_DIR)/usr/lib/libiconv/include/
+EXTRA_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libintl/lib/ -L$(STAGING_DIR)/usr/lib/libiconv/lib/
+
+define Package/gst-plugins-base
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  TITLE:=gst-plugins-base
+  URL:=http://gst-plugins-base.freedesktop.org/
+  DEPENDS:=gstreamer +liboil +pango
+endef
+
+define Package/gst-plugins-base/description
+       gstreamer base plugins
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       --disable-ogg --disable-vorbis\
+                       $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       cd $(PKG_BUILD_DIR) ; DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) all install
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+define Package/gst-plugins-base/install
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+$(eval $(call BuildPackage,gst-plugins-base))
diff --git a/multimedia/gstreamer/Makefile b/multimedia/gstreamer/Makefile
new file mode 100644 (file)
index 0000000..2702ad5
--- /dev/null
@@ -0,0 +1,62 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gstreamer
+PKG_VERSION:=0.10.12
+PKG_RELEASE:=1
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gstreamer/
+PKG_FIXUP:=libtool
+
+include $(INCLUDE_DIR)/package.mk
+
+EXTRA_CFLAGS+= -I$(STAGING_DIR)/usr/lib/libintl/include/ -I$(STAGING_DIR)/usr/lib/libiconv/include/
+EXTRA_LDFLAGS+=-Wl,-rpath-link=$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libintl/lib/ -L$(STAGING_DIR)/usr/lib/libiconv/lib/
+
+define Package/gstreamer
+  SECTION:=multimedia
+  CATEGORY:=Multimedia
+  TITLE:=gstreamer
+  URL:=http://gstreamer.freedesktop.org/
+  DEPENDS:=+libxml2 +check
+  MENU:=1
+endef
+
+define Package/gstreamer/description
+       gnu streamer
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       --disable-tests \
+                       $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       cd $(PKG_BUILD_DIR) ; DESTDIR=$(PKG_INSTALL_DIR) $(MAKE) all install
+       cd $(PKG_INSTALL_DIR)/usr/include/; ln -s gstreamer-0.10/gst/
+endef
+
+define Build/InstallDev
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+define Package/gstreamer/install
+       mkdir -p $(1)
+       cp -r $(PKG_INSTALL_DIR)/* $(1)
+endef
+
+$(eval $(call BuildPackage,gstreamer))