[backfire] packages/openldap: merge r28843
authorNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 11:20:17 +0000 (11:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 9 Nov 2011 11:20:17 +0000 (11:20 +0000)
SVN-Revision: 28877

libs/openldap/Makefile
libs/openldap/files/ldap.init

index 496bb0e6c8d12fee89841c4a94b8feac23f103a4..6165d1f361406e2844cc5d1837db6dd9cdefc765 100644 (file)
@@ -1,5 +1,5 @@
 # 
 # 
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openldap
 PKG_VERSION:=2.4.23
 
 PKG_NAME:=openldap
 PKG_VERSION:=2.4.23
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=ftp://ftp.openldap.org/pub/OpenLDAP/openldap-release/ \
@@ -136,8 +136,12 @@ define Package/openldap-server/install
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/slapd.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/schema/* $(1)/etc/openldap/schema/
        $(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/openldap/slapd.conf $(1)/etc/openldap/
        $(INSTALL_DIR) $(1)/usr/sbin
-       # OpenLDAP installs slapd into libexecdir, not sbindir:
+       # XXX: OpenLDAP installs slapd into libexecdir, not sbindir:
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/slapd $(1)/usr/sbin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/slapd $(1)/usr/sbin/
+       # XXX: switch default backend to ldif, since bdb is disabled
+       $(SED) 's|^\(database\)\([ \t]\+\)bdb|\1\2ldif|g' \
+           -e 's|^\(index\)|#\1|g' \
+           $(1)/etc/openldap/slapd.conf
 endef
 
 $(eval $(call BuildPackage,libopenldap))
 endef
 
 $(eval $(call BuildPackage,libopenldap))
index aae19356e995ddb4c94bbe10eadba66fdb6779ee..dd14b2133d61fb125ed38b0109e9b9a1e7420fbc 100644 (file)
@@ -1,10 +1,10 @@
 #!/bin/sh /etc/rc.common
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2011 OpenWrt.org
 
 START=60
 
 start() {
 
 START=60
 
 start() {
-       mkdir -p /var/run/openldap
+       mkdir -p /var/openldap-data
        
        /usr/sbin/slapd
 }
        
        /usr/sbin/slapd
 }