[backfire/packages] merge r28460
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 15 Oct 2011 18:55:54 +0000 (18:55 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 15 Oct 2011 18:55:54 +0000 (18:55 +0000)
SVN-Revision: 28461

net/wshaper/Makefile
net/wshaper/files/wshaper.htb

index e968fca8b244563d59fcdb4d7375f23ac46f950d..f6c1e07164237579f1c45e36b020e692d09f1894 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
index 96f29cc46994cf0778a86f0bfdca2468f261b318..d8e35adb3159a26d59d5065d2a776e177a7ea145 100755 (executable)
@@ -13,7 +13,7 @@ for s in downlink uplink network nopriohostdst nopriohostsrc noprioportdst nopri
        config_get $s settings $s
 done
 
-device=$(uci_get_state network "$network" device)
+device=$(uci_get_state network "$network" ifname "$network")
 [ -z "$device" ] && logger -t wondershaper "Error: Could not find the device for network $network, aborting." && exit 1
 [ -z "$downlink" ] && logger -t wondershaper "Error: Downlink speed not set, aborting." && exit 1
 [ -z "$uplink" ] && logger -t wondershaper "Error: Uplink speed not set, aborting." && exit 1