added libtiff
authorJohn Crispin <john@openwrt.org>
Fri, 5 Oct 2007 20:27:43 +0000 (20:27 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 5 Oct 2007 20:27:43 +0000 (20:27 +0000)
SVN-Revision: 9147

libs/tiff/Makefile [new file with mode: 0644]

diff --git a/libs/tiff/Makefile b/libs/tiff/Makefile
new file mode 100644 (file)
index 0000000..38cc1b2
--- /dev/null
@@ -0,0 +1,59 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# blogic@openwrt.org
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tiff
+PKG_VERSION:=3.8.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:= http://libtiff.maptools.org/dl/
+
+include $(INCLUDE_DIR)/package.mk
+
+CONFIGURE_ARGS_XTRA+=--without-x
+
+define Package/libtiff
+  SECTION:=libs
+  CATEGORY:=libs
+  SUBMENU:=libraries
+  TITLE:=TIFF libraries
+  DEPENDS:=+zlib +libjpeg
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR)/$(CONFIGURE_PATH); \
+               if [ -x $(CONFIGURE_CMD) ]; then \
+                       $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/ && \
+                       $(CONFIGURE_VARS) \
+                       $(CONFIGURE_CMD) \
+                       $(CONFIGURE_ARGS_XTRA) \
+                       $(CONFIGURE_ARGS) ;\
+               fi \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR)/ install DESTDIR=$(PKG_INSTALL_DIR)
+endef
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(STAGING_DIR)/usr/{lib,include}
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib* $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/
+       $(SED)  "s,"libdir\=\'/usr/lib\'",libdir='$(STAGING_DIR)/usr/lib\'," $(STAGING_DIR)/usr/lib/libtif{f,fxx}.la
+endef
+
+define Package/tiff/Install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libtiff))