ar71xx: merge changes from 3.10 that were forgotten for 3.14
authorFelix Fietkau <nbd@openwrt.org>
Sun, 23 Nov 2014 16:27:19 +0000 (16:27 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 23 Nov 2014 16:27:19 +0000 (16:27 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43347

19 files changed:
target/linux/ar71xx/config-3.14
target/linux/ar71xx/patches-3.14/616-MIPS-ath79-ubnt-xw.patch
target/linux/ar71xx/patches-3.14/634-MIPS-ath79-WNR2000V4-support.patch [new file with mode: 0644]
target/linux/ar71xx/patches-3.14/702-MIPS-ath79-add-MyNet-N750-support.patch
target/linux/ar71xx/patches-3.14/704-MIPS-ath79-TL-WDR4900v2-support.patch
target/linux/ar71xx/patches-3.14/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
target/linux/ar71xx/patches-3.14/708-MIPS-ath79-TL-WR841v9-support.patch
target/linux/ar71xx/patches-3.14/709-MIPS-ath79-add-NBG6716.patch
target/linux/ar71xx/patches-3.14/714-MIPS-ath79-add-TL-WA830REv2-support.patch
target/linux/ar71xx/patches-3.14/720-MIPS-ath79-add-Tube2H-support.patch
target/linux/ar71xx/patches-3.14/722-MIPS-ath79-add-airGateway-support.patch
target/linux/ar71xx/patches-3.14/723-MIPS-ath79-add-om5p-support.patch
target/linux/ar71xx/patches-3.14/724-MIPS-ath79-archer_c5-support.patch
target/linux/ar71xx/patches-3.14/725-MIPS-ath79-add_mikrotik_rb2011uias-2hnd.patch [new file with mode: 0644]
target/linux/ar71xx/patches-3.14/726-MIPS-ath79-add-qihoo-360-c301-support.patch
target/linux/ar71xx/patches-3.14/729-MIPS-ath79-add-WZR-450HP2.patch
target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-DHP-1565A1.patch [new file with mode: 0644]
target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-mr900-support.patch
target/linux/ar71xx/patches-3.14/731-MIPS-ath79-add-mr900v2-support.patch

index acfb3a8443f0d0f7f199a58571bec93c28b706cc..2f1ccce64bb4dc2170ebc7fb35f60744b25b7cd9 100644 (file)
@@ -41,6 +41,7 @@ CONFIG_ATH79_MACH_BHU_BXU2000N2_A=y
 CONFIG_ATH79_MACH_CAP4200AG=y
 CONFIG_ATH79_MACH_CARAMBOLA2=y
 CONFIG_ATH79_MACH_DB120=y
+CONFIG_ATH79_MACH_DHP_1565_A1=y
 CONFIG_ATH79_MACH_DIR_505_A1=y
 CONFIG_ATH79_MACH_DIR_600_A1=y
 CONFIG_ATH79_MACH_DIR_615_C1=y
@@ -120,6 +121,7 @@ CONFIG_ATH79_MACH_WNDR3700=y
 CONFIG_ATH79_MACH_WNDR4300=y
 CONFIG_ATH79_MACH_WNR2000=y
 CONFIG_ATH79_MACH_WNR2000_V3=y
+CONFIG_ATH79_MACH_WNR2000_V4=y
 CONFIG_ATH79_MACH_WNR2200=y
 CONFIG_ATH79_MACH_WP543=y
 CONFIG_ATH79_MACH_WPE72=y
@@ -246,7 +248,6 @@ CONFIG_MTD_REDBOOT_PARTS=y
 CONFIG_MTD_SPLIT_FIRMWARE=y
 CONFIG_MTD_SPLIT_LZMA_FW=y
 CONFIG_MTD_SPLIT_SEAMA_FW=y
-CONFIG_MTD_SPLIT_SQUASHFS_ROOT=y
 CONFIG_MTD_SPLIT_UIMAGE_FW=y
 CONFIG_MTD_TPLINK_PARTS=y
 CONFIG_MTD_WRT160NL_PARTS=y
index ed2fd246ef4898e9d2db304047a22b531b85991a..5e3d4d4000fbae4895305b332e4c3646671155b8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/mach-ubnt-xm.c
 +++ b/arch/mips/ath79/mach-ubnt-xm.c
-@@ -332,3 +332,60 @@ static void __init ubnt_uap_pro_setup(vo
+@@ -332,3 +332,78 @@ static void __init ubnt_uap_pro_setup(vo
  MIPS_MACHINE(ATH79_MACH_UBNT_UAP_PRO, "UAP-PRO", "Ubiquiti UniFi AP Pro",
             ubnt_uap_pro_setup);
  
@@ -29,7 +29,7 @@
 +      },
 +};
 +
-+static void __init ubnt_nano_m_xw_setup(void)
++static void __init ubnt_xw_init(void)
 +{
 +      u8 *eeprom = (u8 *) KSEG1ADDR(0x1fff0000);
 +
 +      ath79_register_wmac(eeprom + UAP_PRO_WMAC_CALDATA_OFFSET, NULL);
 +      ap91_pci_init(eeprom + UAP_PRO_PCI_CALDATA_OFFSET, NULL);
 +
-+      ath79_register_mdio(0, ~(BIT(0) | BIT(1) | BIT(5)));
 +
 +      ath79_setup_ar934x_eth_cfg(AR934X_ETH_CFG_MII_GMAC0 | AR934X_ETH_CFG_MII_GMAC0_SLAVE);
 +      ath79_init_mac(ath79_eth0_data.mac_addr,
 +                     eeprom + UAP_PRO_MAC0_OFFSET, 0);
 +
-+      /* GMAC0 is connected to an AR8326 switch */
 +      ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
++      ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
++}
++
++static void __init ubnt_nano_m_xw_setup(void)
++{
++      ubnt_xw_init();
++
++      /* GMAC0 is connected to an AR8326 switch */
++      ath79_register_mdio(0, ~(BIT(0) | BIT(1) | BIT(5)));
 +      ath79_eth0_data.phy_mask = (BIT(0) | BIT(1) | BIT(5));
 +      ath79_eth0_data.speed = SPEED_100;
 +      ath79_eth0_data.duplex = DUPLEX_FULL;
-+      ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
++      ath79_register_eth(0);
++}
++
++static void __init ubnt_loco_m_xw_setup(void)
++{
++      ubnt_xw_init();
++
++      ath79_register_mdio(0, ~BIT(1));
++      ath79_eth0_data.phy_mask = BIT(1);
 +      ath79_register_eth(0);
 +}
 +
 +MIPS_MACHINE(ATH79_MACH_UBNT_NANO_M_XW, "UBNT-NM-XW", "Ubiquiti Nanostation M XW",
 +           ubnt_nano_m_xw_setup);
++
++MIPS_MACHINE(ATH79_MACH_UBNT_LOCO_M_XW, "UBNT-LOCO-XW", "Ubiquiti Loco M XW",
++           ubnt_loco_m_xw_setup);
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -124,6 +124,7 @@ enum ath79_mach_type {
+@@ -121,9 +121,11 @@ enum ath79_mach_type {
+       ATH79_MACH_TL_WR941ND,          /* TP-LINK TL-WR941ND */
+       ATH79_MACH_UBNT_AIRROUTER,      /* Ubiquiti AirRouter */
+       ATH79_MACH_UBNT_BULLET_M,       /* Ubiquiti Bullet M */
++      ATH79_MACH_UBNT_LOCO_M_XW,      /* Ubiquiti Loco M XW */
        ATH79_MACH_UBNT_LSSR71,         /* Ubiquiti LS-SR71 */
        ATH79_MACH_UBNT_LSX,            /* Ubiquiti LSX */
        ATH79_MACH_UBNT_NANO_M,         /* Ubiquiti NanoStation M */
diff --git a/target/linux/ar71xx/patches-3.14/634-MIPS-ath79-WNR2000V4-support.patch b/target/linux/ar71xx/patches-3.14/634-MIPS-ath79-WNR2000V4-support.patch
new file mode 100644 (file)
index 0000000..5b6ed46
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -470,6 +470,16 @@ config ATH79_MACH_WNR2000_V3
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
++config ATH79_MACH_WNR2000_V4
++      bool "NETGEAR WNR2000 V4"
++      select SOC_AR934X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_OM2P
+       bool "OpenMesh OM2P board support"
+       select SOC_AR724X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -114,6 +114,7 @@ obj-$(CONFIG_ATH79_MACH_WNDR3700)  += mac
+ obj-$(CONFIG_ATH79_MACH_WNDR4300)     += mach-wndr4300.o
+ obj-$(CONFIG_ATH79_MACH_WNR2000)      += mach-wnr2000.o
+ obj-$(CONFIG_ATH79_MACH_WNR2000_V3)   += mach-wnr2000-v3.o
++obj-$(CONFIG_ATH79_MACH_WNR2000_V4)   += mach-wnr2000-v4.o
+ obj-$(CONFIG_ATH79_MACH_WNR2200)      += mach-wnr2200.o
+ obj-$(CONFIG_ATH79_MACH_WP543)                += mach-wp543.o
+ obj-$(CONFIG_ATH79_MACH_WPE72)                += mach-wpe72.o
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -144,6 +144,7 @@ enum ath79_mach_type {
+       ATH79_MACH_WNDR4300,            /* NETGEAR WNDR4300 */
+       ATH79_MACH_WNR2000,             /* NETGEAR WNR2000 */
+       ATH79_MACH_WNR2000_V3,          /* NETGEAR WNR2000 v3 */
++      ATH79_MACH_WNR2000_V4,          /* NETGEAR WNR2000 v4 */
+       ATH79_MACH_WNR2200,             /* NETGEAR WNR2200 */
+       ATH79_MACH_WNR612_V2,           /* NETGEAR WNR612 v2 */
+       ATH79_MACH_WP543,               /* Compex WP543 */
index 07b2fee7e6a42f529f6bbb3fc15e56e6e70cd5e1..452210e218566022bdd08504881e6bb84f8e9e8f 100644 (file)
@@ -10,7 +10,7 @@
        ATH79_MACH_MZK_W300NH,          /* Planex MZK-W300NH */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -820,6 +820,16 @@ config ATH79_MACH_MYNET_N600
+@@ -830,6 +830,16 @@ config ATH79_MACH_MYNET_N600
        select ATH79_DEV_WMAC
        select ATH79_NVRAM
  
index 848109ee5afdf19d04b3b33904fe8019b3a0446d..002d05306a0380699a6a3ad6e5b952f8fdd418a4 100644 (file)
@@ -10,7 +10,7 @@
        ATH79_MACH_TL_WR1043ND_V2,      /* TP-LINK TL-WR1043ND v2 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -549,8 +549,9 @@ config ATH79_MACH_EAP7660D
+@@ -559,8 +559,9 @@ config ATH79_MACH_EAP7660D
        select ATH79_DEV_M25P80
  
  config ATH79_MACH_ARCHER_C7
index 3979ea8fd77b04d9099d52b8803d4946840da7a2..439150a7bd7537ccfb5d03d233e58102a83bfdd1 100644 (file)
@@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -929,6 +929,10 @@ config SOC_AR934X
+@@ -939,6 +939,10 @@ config SOC_AR934X
        select PCI_AR724X if PCI
        def_bool n
  
@@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
  config SOC_QCA955X
        select USB_ARCH_HAS_EHCI
        select HW_HAS_PCI
-@@ -972,7 +976,7 @@ config ATH79_DEV_USB
+@@ -982,7 +986,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
index 89058033788ad095f63e51d26898d8ec9966bfa2..24bed737f21a304c62c40471718d1dd4773482c9 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -716,6 +716,15 @@ config ATH79_MACH_TL_WR841N_V8
+@@ -726,6 +726,15 @@ config ATH79_MACH_TL_WR841N_V8
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
index 8e1a94983c34eb1eb8384edb7bbaff918deb0ef0..70ec89d06f10c2594eaaebd778ee58a22524f7be 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -130,3 +130,4 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H)     +
+@@ -131,3 +131,4 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H)     +
  obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
  obj-$(CONFIG_ATH79_MACH_ZCN_1523H)    += mach-zcn-1523h.o
  obj-$(CONFIG_ATH79_MACH_CARAMBOLA2)   += mach-carambola2.o
@@ -17,7 +17,7 @@
        ATH79_MACH_OM2P,                /* OpenMesh OM2P */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -899,6 +899,17 @@ config ATH79_MACH_NBG460N
+@@ -909,6 +909,17 @@ config ATH79_MACH_NBG460N
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index aedc1bffec48db83cff381c5f37b780befdfd572..7ac66f519277b6f57f32a37e35c2860baf678850 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -656,6 +656,16 @@ config ATH79_MACH_TL_WAX50RE
+@@ -666,6 +666,16 @@ config ATH79_MACH_TL_WAX50RE
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index e8919c4efdb9ad591bfbd47c3771989d57b88b98..856c0e136f00cafc5d404db228d7ab111af89186 100644 (file)
@@ -7,7 +7,7 @@
 +      ATH79_MACH_TUBE2H,              /* Alfa Network Tube2H */
        ATH79_MACH_UBNT_AIRROUTER,      /* Ubiquiti AirRouter */
        ATH79_MACH_UBNT_BULLET_M,       /* Ubiquiti Bullet M */
-       ATH79_MACH_UBNT_LSSR71,         /* Ubiquiti LS-SR71 */
+       ATH79_MACH_UBNT_LOCO_M_XW,      /* Ubiquiti Loco M XW */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
 @@ -29,6 +29,15 @@ config ATH79_MACH_ALFA_NX
index 0fe62d95586d91b28d3de64dcf7acf404ff6fe0e..7ff07b6b214e9b11271fba7dac75dbe52f1c9f29 100644 (file)
  #include "dev-ap9x-pci.h"
  #include "dev-eth.h"
  #include "dev-gpio-buttons.h"
-@@ -389,3 +391,65 @@ static void __init ubnt_nano_m_xw_setup(
+@@ -407,3 +409,65 @@ MIPS_MACHINE(ATH79_MACH_UBNT_NANO_M_XW, 
  
- MIPS_MACHINE(ATH79_MACH_UBNT_NANO_M_XW, "UBNT-NM-XW", "Ubiquiti Nanostation M XW",
-            ubnt_nano_m_xw_setup);
+ MIPS_MACHINE(ATH79_MACH_UBNT_LOCO_M_XW, "UBNT-LOCO-XW", "Ubiquiti Loco M XW",
+            ubnt_loco_m_xw_setup);
 +
 +static struct gpio_led ubnt_airgateway_gpio_leds[] __initdata = {
 +      {
@@ -87,4 +87,4 @@
 +      ATH79_MACH_UBNT_AIRGW,          /* Ubiquiti AirGateway */
        ATH79_MACH_UBNT_AIRROUTER,      /* Ubiquiti AirRouter */
        ATH79_MACH_UBNT_BULLET_M,       /* Ubiquiti Bullet M */
-       ATH79_MACH_UBNT_LSSR71,         /* Ubiquiti LS-SR71 */
+       ATH79_MACH_UBNT_LOCO_M_XW,      /* Ubiquiti Loco M XW */
index e5ce232b89b392f7e50225a947e31783ff3bb506..f3adc9e7f35b9d849960f4cd816dde787e9ed49f 100644 (file)
@@ -10,7 +10,7 @@
        ATH79_MACH_RB_411,              /* MikroTik RouterBOARD 411/411A/411AH */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -587,6 +587,15 @@ config ATH79_MACH_OM2P
+@@ -597,6 +597,15 @@ config ATH79_MACH_OM2P
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
index 0668dfef4370e64402e5ed55cf4238410fa340df..568f72bdbf12c29bca2c52a4d398dc3ef60f6b0f 100644 (file)
@@ -10,7 +10,7 @@
        ATH79_MACH_BHU_BXU2000N2_A1,    /* BHU BXU2000n-2 A1 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -654,7 +654,7 @@ config ATH79_MACH_EAP7660D
+@@ -664,7 +664,7 @@ config ATH79_MACH_EAP7660D
        select ATH79_DEV_M25P80
  
  config ATH79_MACH_ARCHER_C7
diff --git a/target/linux/ar71xx/patches-3.14/725-MIPS-ath79-add_mikrotik_rb2011uias-2hnd.patch b/target/linux/ar71xx/patches-3.14/725-MIPS-ath79-add_mikrotik_rb2011uias-2hnd.patch
new file mode 100644 (file)
index 0000000..f49d713
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/arch/mips/ath79/mach-rb2011.c
++++ b/arch/mips/ath79/mach-rb2011.c
+@@ -323,7 +323,7 @@ MIPS_MACHINE_NONAME(ATH79_MACH_RB_2011US
+ static void __init rb2011r5_setup(void)
+ {
+-      rb2011_setup(RB2011_FLAG_SFP | RB2011_FLAG_USB);
++      rb2011_setup(RB2011_FLAG_SFP | RB2011_FLAG_USB | RB2011_FLAG_WLAN);
+ }
+ MIPS_MACHINE_NONAME(ATH79_MACH_RB_2011R5, "2011r5", rb2011r5_setup);
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -99,7 +99,7 @@ enum ath79_mach_type {
+       ATH79_MACH_RB_2011G,            /* Mikrotik RouterBOARD 2011UAS-2HnD */
+       ATH79_MACH_RB_2011L,            /* Mikrotik RouterBOARD 2011L */
+       ATH79_MACH_RB_2011US,           /* Mikrotik RouterBOARD 2011UAS */
+-      ATH79_MACH_RB_2011R5,           /* Mikrotik RouterBOARD 2011UiAS */
++      ATH79_MACH_RB_2011R5,           /* Mikrotik RouterBOARD 2011UiAS(-2Hnd) */
+       ATH79_MACH_RB_SXTLITE2ND,       /* Mikrotik RouterBOARD SXT Lite 2nD */
+       ATH79_MACH_RB_SXTLITE5ND,       /* Mikrotik RouterBOARD SXT Lite 5nD */
+       ATH79_MACH_RW2458N,             /* Redwave RW2458N */
index c815b147673dc007c83f71202edae7c2fbdf6f40..53e5c394bdad6cf098769cc59fbfe9189f0abb5f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1034,6 +1034,17 @@ config ATH79_MACH_BHU_BXU2000N2_A
+@@ -1044,6 +1044,17 @@ config ATH79_MACH_BHU_BXU2000N2_A
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
index d7364e4b36ab39e458d07c19d5c5aa9d4ca80818..d20eef8046df0e4084ca9738a30b79a32ed81211 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -182,6 +182,7 @@ enum ath79_mach_type {
+@@ -184,6 +184,7 @@ enum ath79_mach_type {
        ATH79_MACH_WZR_HP_G300NH,       /* Buffalo WZR-HP-G300NH */
        ATH79_MACH_WZR_HP_G300NH2,      /* Buffalo WZR-HP-G300NH2 */
        ATH79_MACH_WZR_HP_G450H,        /* Buffalo WZR-HP-G450H */
@@ -29,7 +29,7 @@
        select SOC_AR71XX
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -140,6 +140,7 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH)     +
+@@ -141,6 +141,7 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH)     +
  obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2)       += mach-wzr-hp-g300nh2.o
  obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H)        += mach-wzr-hp-ag300h.o
  obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
diff --git a/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-DHP-1565A1.patch b/target/linux/ar71xx/patches-3.14/730-MIPS-ath79-add-DHP-1565A1.patch
new file mode 100644 (file)
index 0000000..3b2caf1
--- /dev/null
@@ -0,0 +1,40 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -39,6 +39,7 @@ enum ath79_mach_type {
+       ATH79_MACH_CARAMBOLA2,          /* 8devices Carambola2 */
+       ATH79_MACH_DB120,               /* Atheros DB120 reference board */
+       ATH79_MACH_PB44,                /* Atheros PB44 reference board */
++      ATH79_MACH_DHP_1565_A1,         /* D-Link DHP-1565 rev. A1 */
+       ATH79_MACH_DIR_505_A1,          /* D-Link DIR-505 rev. A1 */
+       ATH79_MACH_DIR_600_A1,          /* D-Link DIR-600 rev. A1 */
+       ATH79_MACH_DIR_615_C1,          /* D-Link DIR-615 rev. C1 */
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -293,6 +293,17 @@ config ATH79_MACH_WPE72
+       select ATH79_DEV_USB
+       select MYLOADER
++config ATH79_MACH_DHP_1565_A1
++      bool "D-Link DHP-1565 rev. A1 board support"
++      select SOC_AR934X
++      select ATH79_DEV_AP9X_PCI if PCI
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_DIR_505_A1
+       bool "D-Link DIR-505-A1 support"
+       select SOC_AR933X
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -54,6 +54,7 @@ obj-$(CONFIG_ATH79_MACH_AW_NR580)    += mac
+ obj-$(CONFIG_ATH79_MACH_BHU_BXU2000N2_A)+= mach-bhu-bxu2000n2-a.o
+ obj-$(CONFIG_ATH79_MACH_CAP4200AG)    += mach-cap4200ag.o
+ obj-$(CONFIG_ATH79_MACH_DB120)                += mach-db120.o
++obj-$(CONFIG_ATH79_MACH_DHP_1565_A1)  += mach-dhp-1565-a1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_505_A1)   += mach-dir-505-a1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_600_A1)   += mach-dir-600-a1.o
+ obj-$(CONFIG_ATH79_MACH_DIR_615_C1)   += mach-dir-615-c1.o
index deb6e56aa9312a6a0c43682cf7158bdf1685643c..240a020d3a9a1f292b31fcae9336a3d4e395cd18 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -654,6 +654,16 @@ config ATH79_MACH_CAP4200AG
+@@ -685,6 +685,16 @@ config ATH79_MACH_CAP4200AG
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
@@ -19,7 +19,7 @@
        select SOC_AR71XX
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -74,6 +74,7 @@ obj-$(CONFIG_ATH79_MACH_JA76PF)              += mach
+@@ -75,6 +75,7 @@ obj-$(CONFIG_ATH79_MACH_JA76PF)              += mach
  obj-$(CONFIG_ATH79_MACH_JWAP003)      += mach-jwap003.o
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
  obj-$(CONFIG_ATH79_MACH_MR600)                += mach-mr600.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_MYNET_REXT)   += mach-mynet-rext.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -65,6 +65,7 @@ enum ath79_mach_type {
+@@ -66,6 +66,7 @@ enum ath79_mach_type {
        ATH79_MACH_HORNET_UB,           /* ALFA Networks Hornet-UB */
        ATH79_MACH_MR600V2,             /* OpenMesh MR600v2 */
        ATH79_MACH_MR600,               /* OpenMesh MR600 */
index be51a8e6d60567df381212d789e90f91a678fd7b..b62335f320a52e17dff34e473fea1b6033fa2897 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -66,6 +66,7 @@ enum ath79_mach_type {
+@@ -67,6 +67,7 @@ enum ath79_mach_type {
        ATH79_MACH_MR600V2,             /* OpenMesh MR600v2 */
        ATH79_MACH_MR600,               /* OpenMesh MR600 */
        ATH79_MACH_MR900,               /* OpenMesh MR900 */