[package] add peervpn package Makefile
authorFlorian Fainelli <florian@openwrt.org>
Wed, 8 Aug 2012 15:38:45 +0000 (15:38 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 8 Aug 2012 15:38:45 +0000 (15:38 +0000)
PeerVPN (http://www.peervpn.net/), by Tobias Volk, is software that
builds virtual ethernet networks between multiple computers. A virtual
network built by PeerVPN uses a full mesh topology. All nodes talk
directly to each other, there is no need for a central server. If one
node goes down, the rest of the network is unaffected.

Configuring PeerVPN is easy. You just need to configure an encryption
key, network name and the contact information (IP address and port) of
some other PeerVPN nodes. Adding a new node to an existing network
doesn't require the existing nodes to alter their configuration,
because its IP address is automatically distributed across the whole
virtual network.

Signed-off-by: Dan VerWeire <dverweire@gmail.com>
SVN-Revision: 33060

net/peervpn/Makefile [new file with mode: 0644]

diff --git a/net/peervpn/Makefile b/net/peervpn/Makefile
new file mode 100644 (file)
index 0000000..695191c
--- /dev/null
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2007-2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=peervpn
+PKG_VERSION:=0-023
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL :=http://www.peervpn.net/files
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/peervpn
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=PeerVPN the open source peer-to-peer VPN
+  URL:=http://www.peervpn.net/
+  DEPENDS:=+libopenssl +ip
+endef
+
+define Package/peervpn/description
+  PeerVPN is software that builds virtual ethernet networks between multiple
+  computers. Adding a new node to an existing network doesn't require the
+  existing nodes to alter their configuration, because its IP address is
+  automatically distributed across the whole virtual network.
+endef
+
+define Package/peervpn/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/peervpn $(1)/sbin/
+       $(INSTALL_DIR) $(1)/etc/peervpn
+       $(INSTALL_CONF) $(PKG_BUILD_DIR)/peervpn.conf $(1)/etc/peervpn
+endef
+
+$(eval $(call BuildPackage,peervpn))