fix numerous typos in Makefile
authorMike Baker <mbm@openwrt.org>
Wed, 16 Aug 2006 23:52:14 +0000 (23:52 +0000)
committerMike Baker <mbm@openwrt.org>
Wed, 16 Aug 2006 23:52:14 +0000 (23:52 +0000)
SVN-Revision: 4574

net/mini_httpd/Makefile

index 43f7793bcbf2ddb868d4fce837f30655fb1bead5..c405abacd81d6dd12dbb63abb1ebf10d7b0931d7 100644 (file)
@@ -48,60 +48,28 @@ endef
 define Package/mini-httpd-htpasswd
   $(call Package/mini-httpd)
   TITLE:=Utility to generate HTTP access files
-  DESCRIPTION:=This file generates .htaccess/.htpasswd files to use HTTP access authentication\\\
+  DESCRIPTION+=This package generates .htaccess/.htpasswd files to use HTTP access authentication
 endef
 
 define Package/mini-httpd-matrixssl
   $(call Package/mini-httpd)
   TITLE:=A small web server, built with SSL support using MatrixSSL
-  DESCRIPTION:=mini_httpd is a small HTTP server. Its performance is not great, but for\\\
-low or medium traffic sites it's quite adequate. It implements all the\\\
-basic features of an HTTP server, including:\\\
-\\\
-* GET, HEAD, and POST methods.\\\
-* CGI.\\\
-* Basic authentication.\\\
-* Security against ".." filename snooping.\\\
-* The common MIME types.\\\
-* Trailing-slash redirection.\\\
-* index.html, index.htm, index.cgi\\\
-* Directory listings.\\\
-* Multihoming / virtual hosting.\\\
-* Standard logging.\\\
-* Custom error pages.\\\
-\\\
-It can also be configured to do SSL/HTTPS and IPv6.\\\
+  DESCRIPTION+=This package adds SSL/HTTPS. (MatrixSSL)
 endef
 
 define Package/mini-httpd-openssl
   $(call BuildPackage,mini-httpd)
   TITLE:=A small web server, built with SSL support using OpenSSL
-  DESCRIPTION:=mini_httpd is a small HTTP server. Its performance is not great, but for\\\
-low or medium traffic sites it's quite adequate. It implements all the\\\
-basic features of an HTTP server, including:\\\
-\\\
-* GET, HEAD, and POST methods.\\\
-* CGI.\\\
-* Basic authentication.\\\
-* Security against ".." filename snooping.\\\
-* The common MIME types.\\\
-* Trailing-slash redirection.\\\
-* index.html, index.htm, index.cgi\\\
-* Directory listings.\\\
-* Multihoming / virtual hosting.\\\
-* Standard logging.\\\
-* Custom error pages.\\\
-\\\
-It can also be configured to do SSL/HTTPS and IPv6.\\\
+  DESCRIPTION+=This package adds SSL/HTTPS. (OpenSSL)
 endef
 
 define Build/Configure
        $(CP) ./files/matrixssl_helper.{c,h} $(PKG_BUILD_DIR)/
-enddef
+endef
 
 define Build/Compile   
        # with MatrixSSL
-ifneq ($(BR2_PACKAGE_MINI_HTTPD_MATRIXSSL),)
+  ifneq ($(BR2_PACKAGE_MINI_HTTPD_MATRIXSSL),)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) \
                OFLAGS="$(TARGET_CFLAGS)" \
@@ -112,9 +80,9 @@ ifneq ($(BR2_PACKAGE_MINI_HTTPD_MATRIXSSL),)
                all
        (cd $(PKG_BUILD_DIR); mv mini_httpd mini_httpd-matrixssl; )
        $(MAKE) -C $(PKG_BUILD_DIR) clean
-endif
+  endif
        # with OpenSSL
-ifneq ($(BR2_PACKAGE_MINI_HTTPD_OPENSSL),)
+  ifneq ($(BR2_PACKAGE_MINI_HTTPD_OPENSSL),)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) \
                OFLAGS="$(TARGET_CFLAGS)" \
@@ -124,14 +92,14 @@ ifneq ($(BR2_PACKAGE_MINI_HTTPD_OPENSSL),)
                all
        (cd $(PKG_BUILD_DIR); mv mini_httpd mini_httpd-openssl; )
        $(MAKE) -C $(PKG_BUILD_DIR) clean
-endif
+  endif
        # without SSL
-ifneq ($(BR2_PACKAGE_MINI_HTTPD),)
+  ifneq ($(BR2_PACKAGE_MINI_HTTPD),)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC=$(TARGET_CC) \
                OFLAGS="$(TARGET_CFLAGS)" \
                all
-endif
+  endif
        touch $@
 
 $(IPKG_MINI_HTTPD):
@@ -177,3 +145,4 @@ $(IPKG_MINI_HTTPD_OPENSSL):
        install -m0755 $(PKG_BUILD_DIR)/mini_httpd-openssl $(IDIR_MINI_HTTPD_OPENSSL)/usr/sbin/mini_httpd
        $(RSTRIP) $(IDIR_MINI_HTTPD_OPENSSL)
        $(IPKG_BUILD) $(IDIR_MINI_HTTPD_OPENSSL) $(PACKAGE_DIR)
+endef