[package] udev: bump to 173
authorFlorian Fainelli <florian@openwrt.org>
Thu, 25 Aug 2011 10:49:29 +0000 (10:49 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 25 Aug 2011 10:49:29 +0000 (10:49 +0000)
Yet another update, I inherited a wrong behaviour with older versions.
It used to $(INSTALL_BIN) symlinks which results in copying the dereferenced
file and not the symlink itself, now uses $(CP) and it's reported working (and running)
by at least one person in IRC (using a glibc toolchain with mips). Works and runs on
my toolchain (mipsel uClibc) too.

Signed-off-by: Daniel Mierswa <impulze@impulze.org>
SVN-Revision: 28085

package/udev/Config.in
package/udev/Makefile
package/udev/patches/0001-build-don-t-use-gc-sections.patch [new file with mode: 0644]
package/udev/patches/0002-udevd-add-lrt-for-message-queue-symbols.patch [new file with mode: 0644]

index 9144c40eda7d2ae59c3ce79ea9222da7bf2a4fb2..56033d8eeee1e7a96db9b85041f756f2538de1ff 100644 (file)
@@ -17,6 +17,13 @@ config UDEV_ENABLE_DEBUG
         Compile in udev debug messages.  If unsure, choose
         the default N.
 
+config UDEV_EXTRA_accelerometer
+       bool "Install udev acceleroometer callout"
+       default y
+       help
+        accelerometer - udev callout to export device orientation
+        through property
+
 config UDEV_EXTRA_ata_id
        bool "Install udev ata_id callout"
        default y
@@ -58,11 +65,17 @@ config UDEV_EXTRA_floppy
         create_floppy_devices - udev callout to create all
         possible floppy device based on the CMOS type
 
-config UDEV_EXTRA_fstab_import
-       bool "Install fstab import"
+config UDEV_EXTRA_input_id
+       bool "Install input_id callout"
+       default y
+       help
+        input_id - udev callout to classify input devices
+
+config UDEV_EXTRA_mtd_probe
+       bool "Install mtd_probe callout"
        default y
        help
-        find matching entry in fstab and export it
+        mtd_probe - udev callout to probe mtd devices
 
 config UDEV_EXTRA_path_id
        bool "Install udev path_id callout"
@@ -72,6 +85,13 @@ config UDEV_EXTRA_path_id
         unique name for a device to implement the Linux
         Persistent Device Naming scheme
 
+config UDEV_EXTRA_qemu
+       bool "Install qemu specific rules"
+       default y
+       help
+        Install rules for autosuspension of QEMU emulated
+        USB HID devices
+
 config UDEV_EXTRA_rule_generator
        bool "Install udev rule_generator"
        default y
@@ -89,4 +109,10 @@ config UDEV_EXTRA_usb_id
        help
          usb_id - can find the unique id of USB devices
 
+config UDEV_EXTRA_v4l_id
+       bool "Install udev v4l_id callout"
+       default y
+       help
+        v4l_id - udev callout to identify Video4Linux devices
+
 endmenu
index 2f7dd614e569977159d12add29b144ea5761cb98..7673be76f393b8c8ef4327123fd8a271a7a6163f 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=udev
-PKG_VERSION:=142
+PKG_VERSION:=173
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/hotplug/
-PKG_MD5SUM:=3edc4cf383dccb06d866c5156d59ddd5
+PKG_MD5SUM:=91a88a359b60bbd074b024883cc0dbde
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,6 +26,7 @@ define Package/udev
   URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
   MAINTAINER:=Geoff Levand <geoffrey.levand@am.sony.com>
   MENU:=1
+  DEPENDS:=+librt
 endef
 
 define Package/udev/description
@@ -43,10 +44,19 @@ endef
 
 udev-args-$(CONFIG_UDEV_DISABLE_LOGGING) += --disable-logging
 udev-args-$(CONFIG_UDEV_ENABLE_DEBUG) += --enable-debug
+udev-args-$(CONFIG_UDEV_EXTRA_edd_id) += --enable-edd
+udev-args-$(CONFIG_UDEV_EXTRA_floppy) += --enable-floppy
+
+# TODO: make hwdb and introspection work
 
 CONFIGURE_ARGS += --prefix=/usr --exec-prefix= --sysconfdir=/etc \
+       --disable-hwdb --disable-keymap --disable-gudev --disable-introspection \
+       --libexecdir=/lib/udev --disable-gtk-doc-html \
        --sbindir=/sbin $(udev-args-y)
 
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_accelerometer) += accelerometer
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_accelerometer) += 61-accelerometer.rules
+
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_ata_id) += ata_id
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_cdrom_id) += cdrom_id
@@ -57,16 +67,24 @@ udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_collect) += collect
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_edd_id) += edd_id
 udev-extra-rules-$(CONFIG_UDEV_EXTRA_edd_id) += 61-persistent-storage-edd.rules
 
-udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_firmware) += firmware.sh
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_firmware) += firmware
 udev-extra-rules-$(CONFIG_UDEV_EXTRA_firmware) += 50-firmware.rules
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_floppy) += create_floppy_devices
 
-udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_fstab_import) += fstab_import
-udev-extra-rules-$(CONFIG_UDEV_EXTRA_fstab_import) += 79-fstab_import.rules
+# TODO: make gudev work
+
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_input_id) += input_id
+
+# TODO: make keymap work
+
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_mtd_probe) += mtd_probe
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_mtd_probe) += 75-probe_mtd.rules
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_path_id) += path_id
 
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_qemu) += 42-qemu-usb.rules
+
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_rule_generator) += \
        write_cd_rules write_net_rules
 udev-extra-lib-data-$(CONFIG_UDEV_EXTRA_rule_generator) += \
@@ -76,17 +94,22 @@ udev-extra-rules-$(CONFIG_UDEV_EXTRA_rule_generator) += \
 
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_scsi_id) += scsi_id
 
+# TODO: make udev-acl work
+
 udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_usb_id) += usb_id
 
+udev-extra-lib-bin-$(CONFIG_UDEV_EXTRA_v4l_id) += v4l_id
+udev-extra-rules-$(CONFIG_UDEV_EXTRA_v4l_id) += 60-persistent-v4l.rules
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/libudev.h $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/share/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/pkgconfig/udev.pc $(1)/usr/share/pkgconfig
        $(INSTALL_DIR) $(1)/lib
        $(CP) $(PKG_INSTALL_DIR)/lib/libudev.so* $(1)/lib
-       $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libudev.so $(1)/usr/lib
        $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libudev.pc $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/lib/pkgconfig/libudev.pc $(1)/usr/lib/pkgconfig
 endef
 
 define Package/udev/install
@@ -113,9 +136,7 @@ define Package/udev/install
                $(1)/lib/udev/rules.d
 
        $(INSTALL_DIR) $(1)/lib
-       $(INSTALL_BIN) \
-               $(PKG_INSTALL_DIR)/lib/libudev.so.* \
-               $(1)/lib
+       $(CP) $(PKG_INSTALL_DIR)/lib/libudev.so* $(1)/lib
 
        $(INSTALL_DIR) $(1)/lib/udev
 ifneq ($(udev-extra-lib-bin-y),)
diff --git a/package/udev/patches/0001-build-don-t-use-gc-sections.patch b/package/udev/patches/0001-build-don-t-use-gc-sections.patch
new file mode 100644 (file)
index 0000000..f01a5ae
--- /dev/null
@@ -0,0 +1,31 @@
+From 971a09345f108189ed899b236784a5440e43c8b6 Mon Sep 17 00:00:00 2001
+From: Daniel Mierswa <impulze@impulze.org>
+Date: Sun, 31 Jul 2011 23:51:49 +0000
+Subject: [PATCH 1/2] build: don't use --gc-sections
+
+somehow won't work with the wrt toolchain
+---
+ Makefile.am |    5 +----
+ 1 files changed, 1 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index a0c007a..3d8ce92 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -18,12 +18,9 @@ AM_CPPFLAGS = \
+       -DLIBEXECDIR=\""$(libexecdir)"\"
+ AM_CFLAGS = \
+-      -fvisibility=hidden \
+-      -ffunction-sections \
+-      -fdata-sections
++      -fvisibility=hidden
+ AM_LDFLAGS = \
+-      -Wl,--gc-sections \
+       -Wl,--as-needed
+ DISTCHECK_CONFIGURE_FLAGS = \
+-- 
+1.7.6
+
diff --git a/package/udev/patches/0002-udevd-add-lrt-for-message-queue-symbols.patch b/package/udev/patches/0002-udevd-add-lrt-for-message-queue-symbols.patch
new file mode 100644 (file)
index 0000000..55466bc
--- /dev/null
@@ -0,0 +1,25 @@
+From ae90737100d901723af9890e69798bd1dac9a86d Mon Sep 17 00:00:00 2001
+From: Daniel Mierswa <impulze@impulze.org>
+Date: Sun, 31 Jul 2011 23:53:21 +0000
+Subject: [PATCH 2/2] udevd: add -lrt for message queue symbols
+
+---
+ Makefile.am |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 3d8ce92..7d8a4b6 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -164,7 +164,7 @@ udev_udevd_SOURCES = \
+       udev/udevd.c \
+       udev/sd-daemon.h \
+       udev/sd-daemon.c
+-udev_udevd_LDADD = libudev/libudev-private.la
++udev_udevd_LDADD = libudev/libudev-private.la -lrt
+ udev_udevadm_SOURCES = \
+       $(udev_common_sources) \
+-- 
+1.7.6
+