packages: uboot-mxs: bump to 2015.07, refresh Duckbill patch
authorZoltan Herpai <wigyori@uid0.hu>
Fri, 31 Jul 2015 11:52:48 +0000 (11:52 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Fri, 31 Jul 2015 11:52:48 +0000 (11:52 +0000)
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 46523

package/boot/uboot-mxs/Makefile
package/boot/uboot-mxs/patches/001-add-i2se-duckbill.patch

index 532c7a58ca3fee47a799d442a493447e4af040b8..1686f60a18932b298dbb94953ab17f827075a573 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2015.01
+PKG_VERSION:=2015.07
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=7f08dc9e98a71652bd6968888ed6ec95
+PKG_MD5SUM:=3dac9a0b46fed77fc768ad3bd2d68c05
 
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
 
 PKG_LICENSE:=GPL-2.0 GPL-2.0+
 PKG_LICENSE_FILES:=Licenses/README
@@ -30,11 +30,11 @@ define uboot/Default
 endef
 
 define uboot/mx23_olinuxino
 endef
 
 define uboot/mx23_olinuxino
-  TITLE:=U-Boot 2015.01 for the Olinuxino i.MX233
+  TITLE:=U-Boot 2015.07 for the Olinuxino i.MX233
 endef
 
 define uboot/duckbill
 endef
 
 define uboot/duckbill
-  TITLE:=U-Boot 2015.01 for the I2SE Duckbill
+  TITLE:=U-Boot 2015.07 for the I2SE Duckbill
 endef
 
 UBOOTS := \
 endef
 
 UBOOTS := \
index 39a29ade8c400cd6cdba500b4c2af06ac53fe7c4..30bb840dcea970e66977764096cbd985dc0b0d97 100644 (file)
@@ -52,9 +52,9 @@ index d4a447b..5c71573 100644
 --- a/arch/arm/include/asm/mach-types.h
 +++ b/arch/arm/include/asm/mach-types.h
 @@ -1108,6 +1108,8 @@ extern unsigned int __machine_arch_type;
 --- a/arch/arm/include/asm/mach-types.h
 +++ b/arch/arm/include/asm/mach-types.h
 @@ -1108,6 +1108,8 @@ extern unsigned int __machine_arch_type;
- #define MACH_TYPE_KZM9G                4140
  #define MACH_TYPE_COLIBRI_T30          4493
  #define MACH_TYPE_APALIS_T30           4513
  #define MACH_TYPE_COLIBRI_T30          4493
  #define MACH_TYPE_APALIS_T30           4513
+ #define MACH_TYPE_OMAPL138_LCDK        2495
 +#define MACH_TYPE_DUCKBILL             4754
 +
  
 +#define MACH_TYPE_DUCKBILL             4754
 +