packages/scanlogd: change chroot to /var/run/scanlogd, use new service functions...
authorNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2011 01:30:25 +0000 (01:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2011 01:30:25 +0000 (01:30 +0000)
SVN-Revision: 28967

net/scanlogd/Makefile
net/scanlogd/files/scanlogd.init

index 81ae587b0a74060358b71892c14f85f8730b8d18..6b7305e6d76fd8233ae639cdf063bfc2f9ef3416 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=scanlogd
 PKG_VERSION:=2.2.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openwall.com/scanlogd/ \
@@ -38,8 +38,9 @@ define Package/scanlogd/description
 endef
 
 define Build/Configure 
-       $(SED) "s,/var/empty,/tmp/.scanlogd," $(PKG_BUILD_DIR)/params.h
-       $(SED) "s,#undef SCANLOGD_DEVICE,#define SCANLOGD_DEVICE \"all\"," $(PKG_BUILD_DIR)/params.h
+       $(SED) 's,^#define \(SCANLOGD_CHROOT\).*,#define \1 "/var/run/scanlogd",' \
+           -e 's,^#undef \(SCANLOGD_DEVICE\),#define \1 "all",' \
+           $(PKG_BUILD_DIR)/params.h
 endef
 
 define Build/Compile   
index 8c6f38298fd39934105d215eb001e90364f93c86..cfe5825bde4edb3b87deae0e75bf0ec759290f57 100644 (file)
@@ -1,12 +1,19 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006 OpenWrt.org
+
 START=50
 
 start() {
-       mkdir -p `grep "^scanlogd:" /etc/passwd | cut -d: -f6`
-       /usr/sbin/scanlogd
+       user_exists scanlogd 51 || user_add scanlogd 51
+       group_exists scanlogd 51 || group_add scanlogd
+       [ -d  /var/run/scanlogd ] || {
+               mkdir -m 0755 -p /var/run/scanlogd
+               chmod 0755 /var/run/scanlogd
+               chown scanlogd:scanlogd /var/run/scanlogd
+       }
+       service_start /usr/sbin/scanlogd
 }
 
 stop() {
-       killall scanlogd
+       service_stop /usr/sbin/scanlogd
 }