Port fprobe to -ng
authorFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 20:40:05 +0000 (20:40 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 1 Aug 2006 20:40:05 +0000 (20:40 +0000)
SVN-Revision: 4381

net/fprobe/Makefile [new file with mode: 0644]

diff --git a/net/fprobe/Makefile b/net/fprobe/Makefile
new file mode 100644 (file)
index 0000000..1ba4fb5
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME := fprobe
+PKG_VERSION := 1.1
+PKG_RELEASE := 1
+PKG_MD5SUM := 65850d0470078269b33eee58cba77ac2
+
+PKG_SOURCE := $(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL := @SF/fprobe
+PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT := bzcat
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fprobe
+  SECTION:=net
+  CATEGORY:=Network
+  DEPENDS:=+libpcap
+  TITLE:=NetFlow probe (libpcap-based)
+  DESCRIPTION:=A NetFlow probe using libpcap
+  URL:=http://fprobe.sourceforge.net/
+endef
+
+define Build/Configure
+$(call Build/Configure/Default,--with-piddir=/var \
+--with-pcap=$(STAGING_DIR)/usr/include \
+--with-libpcap=$(STAGING_DIR)/usr/lib \
+--with-membulk=index8 \
+--with-hash=xor8 \
+)
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Package/fprobe/install
+       mkdir -p $(1)/usr/bin
+       $(CP) $(PKG_BUILD_DIR)/src/fprobe $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,fprobe))